Installation / Removal > Rockbox Utility

Failed installation of Rockbox on iPod Classic 6G (Windows)


Hi all, decided to install Rockbox on my day off. iPod was formatted in FAT32 (Has never even seen a Mac before), was in disk mode. Booted into the Rockbox bootloader fine, but couldn't restart, I restarted it manually like it told me to but it could not remount the iPod. I was stuck in the USB mode, which would panic if I tried unplugging the iPod (expected). I wasn't sure how to restart so that I could start the installation from scratch, so I held down SELECT and MENU until the screen turned off, and now there is no activity on the screen, no matter what way the lock button is. Windows is no longer seeing it as a drive, meaning the Utility can't see it anymore, and iTunes detects that there's an iPod but errors out when I try to recover it (while also linking to a 404 page lol). Any ideas what steps I can take to at least get a useable iPod again?

It sounds like you installed the bootloader but not rockbox so you are getting stuck in the bootloader. That or there's some disk problem that prevents the bootloader from finding rockbox.

Either way I'd reboot back into the apple firmware and check that you have a .rockbox folder . If you do and it's still not working then there's probably some disk issue or compatibility problem if you've got a 3rd party disk.


[0] Message Index

Go to full version