Installation / Removal > Iriver - Installation/Removal/Flashing

IHP 100 cannot install later than 3.13, need Bootloader V8


Hi there,

I want to update to 128GB SD in CF adapter because i read bootloader V8 was released some years ago, which solved many problems around modern storage cards.
My situation is IHP100, 3.13 installed to RAM/ROM/DISK.
Original Firmware replaced because of 32GB Kingston CF mod back in 2011.
Bootloader 7pre4.
Original 10gig HDD existent.

Thing is i need a daily or dev build for installing pre release bootloaders. The installed 3.13 is a stable version. So i can't flash 7pre5 or V8 with iriver flash.
Also i cant install daily 3.15 with the installer because it needs to flash the modified hex via OF (remember i don't have the OF, i flashed it with rombox).
In the last two days i tried several things to work around this issue but to no avail.
How can i get v8 or 3.15 on my IHP100?

To further notice. I downloaded the 1.63 to 1.65 hex files, descrambled them and pushed them on the hard drive. I tried to flash the resulting bin files with iriver_flash. I get the message "unknown file type". Also i reformatted to fat32 MBR and ran chkdsk /r. Again, same result.

I tried manual install of daily 3.15 again.
So i copied the .rockbox folder to the original hard drive. Interestingly, it will boot. But it takes forever. Like 10 minutes until the UI is finally showing. Also the Iriver is getting very hot. However, when finally booted, i tried flashing the v8 bootloader but sadly when i click on "open with" it freezes while searching the applications. Left it on over the night, hoping it would show me iriver_flash. But no, sadly it didn't. It's weird. I would say something is wrong with the file system. But i double checked everything. Also it boots 3.13 fine and plays music without a single issue. No matter if from Ram, Rom or disk.
I wish anyone could come up with an idea.


[0] Message Index

Go to full version