Support and General Use > Hardware

Surfans f20 (2.7)


Hi there, just got myself a surfans f20 running 2.7 firmware which I find really buggy so wanted to rockbox it! I tried the utility but it won't recognize my player and won't allow me to select a different install drive, it's selecting my internal SSD for some reason, so I found the prepatched firmware for 2.7 and installed that then the latest build for the Eros q/k and unpacked that to the root of the card , the boot loader works fine, the original firmware works as it did before but rockbox won't build the database or play any files, if I select any files to play it crashes and restarted if I try to build the database it errors out with this error:
Bus error at 000327c3
Address (nill)
Rockbox.erosq (rb_back trace0x44) [0x4812q4]

Anyone got any ideas where I went wrong???

Ok, so I've been fighting with this alllllllllll day and as a final last hope I tried a different SD card and guess what? Yep, it worked.... so I've formatted the first card as it's the biggest I have and I'm currently recopying everything to it to try it again but it seems it was just some card issue ....

Hmm I wonder if this is the same issue we've seen in sansa land with multiboot

currently the bootloader is less selective about what constitutes a valid drive and the firmware doesn't agree and rejects it


[0] Message Index

Go to full version