Support and General Use > Plugins/Viewers

Problem with the Shortcuts Plugin?

(1/7) > >>

The following occurs with an iPod Classic 7th Gen running dev build 873f49b1f0-230829.

I'm trying to create a .link file and I can't seem to get it to work.  I want the file to contain a list of directories that represent specific albums in my music library.  So I created a plain text file named (which is just a temporary throwaway name for testing purposes).  Here is the contents of the file:

#Display last path segments=1
/_dtgLIB/Compilations/Baroque Music For Trumpets/
/_dtgLIB/Erich Kunzel_ Cincinnati Pops Orchestra/William Tell & Other Favorite Overtures/

The '/' at the end of the last visible line is followed by a return char.

I know that these paths are correct because I copied them from working pathnames in a working playlist file.

When I 'Play' the .link file I correctly see the last element of the paths in each of the file's two data lines, with "Shortcuts (sealed)" as a title at the top of the list.  When I have a line highlighted and then hit the Select button, my iPod freezes.  I also tried adding another path, this one to a .m4a file (with no '/' at the end of that line) and that froze, too, when I tried to play it from the .link file.

Am I doing something wrong?


My failed attempt to create a working .link file as described above was done on a Mac, so I thought I should try again on a Windows machine.  First I added two working links to my shortcuts.txt file by selecting directories in the file browser and then using the context menu item "Add to Shortcuts".  Then I verified that those links worked from the Shortcuts menu.  Then I cloned the shortcuts.txt file, edited the clone to include only the two links plus the "#Display last path segments=1" line at the top, saved the cloned file, and then changed its name to (overwriting the previous file with the same name).  When I "Played" this new .link file I saw the correct list of links but when I tried to use either of the links the iPod froze again, just like before.

I'm still at it, and finding a little bit of success:

Now instead of trying to "Play" the .link file, I long clicked the Select button on it in the file browser which brought up the context menu from which I selected "Open With...", and then selected "shortcuts_view".  That brought up the same correct menu of links from my .link file.  When I highlighted a link and clicked the Select button, the list's title - "Shortcuts (sealed)" - briefly disappeared and then reappeared but there was no other action.  So I clicked the iPod's |<< button and guess what?  I found myself inside the directory that the link points to.  So the Shortcuts Plugin is kind of working, but not in the intended way as described in the user manual, nor in a way that is direct enough to be particularly practical or useful.

Confirmed its a bug I'll let you know when its fixed

Thank you very much.


[0] Message Index

[#] Next page

Go to full version