Rockbox General > Rockbox General Discussion

"Permission denied" three times when trying to install RB to iPod Mini gen 1.

(1/2) > >>

I tried asking this in the IRC but the server keeps D/Cing me. Sorry if this is the wrong forum.

I've used Rockbox on other devices before and I love it. Rockbox is really great. I came into possession of a iPod Mini generation 1 with a dead hard drive and like so many other people I went to replace it with CF card. I went onto my Manjaro since appimage works on Manjaro machine and downloaded the latest Rockbox and went install it. I tried to install and just an error popup that just said permission denied three times. Here is a screenshot.

I didn't know what that meant but it offered to save a log file, so I looked at that. It gave like 300 lines of just details of my PC but the top has the actual logs, and it just said the same thing again.

***************  Logger   *******************
Could not open Ipod: permission denied
Could not open Ipod: permission denied
Could not open Ipod: permission denied

************  SYSTEMINFO  *******************

So this has never happened with Rockbox before. I could not find anything on the wiki about it. Do any of you happen to have any idea what is going on here? Rockbox has always worked really well before. I don't know what to do. Can someone help me, please?

Thank you for reading.

Bootloader installation requires direct access to the disk. Run with sudo for this part.

Okay, I googled how to run an appimage program as root and all of the results were forum threads saying "don't run appimage programs as root, never do that."
So uhh, ignoring those guys how do I run an appimage program, which rockbox is, as root?

If you want to modify the disk on your device without root you're going to need to switch to an operating system that allows user privilege programs to modify the underlying disk hardware (just don't run any bad programs that modify the file system to give themselves root :o )

Does normal sudo not work?

I am sorry, I don't know. I wanted to try it and looked up how and only found out that you're not supposed to be able to launch .appimage programs from the terminal in the first place. Like this thread:

>The whole philosophy behind AppImages — as well as Snaps and FlatPaks — is that the applications in question would not be integrated with the rest of the system, and therefore, you cannot have your cake and eat it at the same time.

>If you want to open an AppImage from the command line, then you’re going to have to create a script that mounts the image and runs the executable contained in the image.

So I have no idea if sudo works because apparently with .appimage stuff you're not supposed to be able to open a terminal and do something like 'sudo rockboxtool.appimage' without coding your own launcher, which I don't know how to write.


[0] Message Index

[#] Next page

Go to full version