Support and General Use > Hardware

Bricked iPod Classic 7th gen :( hardware problem?


Bricked my 7th gen iPod Classic - won't restore even with iTunes.

I've used this iPod for 13 years, the 160gb hdd died of course and in 2019 I’ve modded it with iFlash installed Rockbox and used it without a single problem. what happened is that the other day I've dropped it, as usual the SD card was out, so I've reinserted it and it continued functioning like it always did.
Except that in a matter of hours it didn't boot anymore, and showed the "can't find rockbox.ipod" error. SDRAM and other tests are OK, but if you need specific info about those I will write exact what it says in the screen.

Btw I said aiight, sd card must be gone, used it 4 years straight, just let it go. So I've replaced it with another fat32 128gb, plugged in on DFU mode.

iTunes (not the microsoft store version of course) will start the restoring, but will stop while "preparing ipod for restore", just when the loading bar is reaching the end. iPod disconnects, resets itself and enters on Disk Mode. Then a "Disk H:" will popup on Windows Explorer but if I click on it, it will load for 2 minutes and then the "Please insert a disk on H: drive" error pops up. At this point iTunes is not seeing the iPod anymore.

I’ve tried so far with 2 different Win10 PCs, and got the same results except that in one Rockbox can’t find the mount point of the iPod while the other does. But in both iTunes can’t perform the restore.

What can I do? please help :(

  Is it a single-card iflash?  One thing that's happened a couple of times is that certain cards refused to work together in the same ipod, but would work fine if I swapped them between different ipods so those two were no longer paired.  But sounds as if you are talking about a single-card one.

Another possibility is it's the drive cable.  Could try swapping that with a new one (it might have fractured, or just gotten slightly loose in the iflash connector?)

Could the battery be flaking out during the restore process?  Is the battery cable intact?

Have you tested the cards themselves via something like h2testw?

After many attempts of all kind, I’ve found out the problem was in the ribbon cable that was a little bit corroded in one pin. After cleaning it with isopropyl alcol now it works fine, I’ve managed to reinstall both iPod OS and Rockbox. Cheers  ;D


[0] Message Index

Go to full version