Rockbox General > Rockbox General Discussion

"cannot open device" - SonyNWDestTool


Hi guys, I installed the Sony Tool ( to change my language on a Sony NW-A45 japanese version I purchased on ebay.

All went okay initially, I ran "scsitool-nwz-vX.exe H: dest_tool get" and it showed the
Model: xxx
Series: xxx
Destination: xxx
Sound pressure: xxx


However after I tried to change the Language setting, it came up with a list of commands with the regions I could use and other settings.

Then when I tried to run "scsitool-nwz-vX.exe H: dest_tool get" again to check if any setting were applied,  I got the message "cannot open device".

Tried again several times and keep getting the same message.

Can anyone give me any advice?

I just saw this post, so maybe already fixed.  I recently used same tool (version 27) on a new Japanese (boxed & sealed) NW-ZX300 (from Japan, via eBay).  I also got the "cannot open device" message, but after a reset i was able to complete the task.


[0] Message Index

Go to full version