Installation / Removal > Sandisk - Installation/Removal

Installing RockBox 3.15 on Sansa Fuze V2 (e280v2) fails to patch bootloader

(1/2) > >>

Hi Everybody,
after running Rockbox very happy on my old Sansa Clip Zip for years, I'm ready to find a new hardware as the Clip Zip is starting to wear off. So I got myself a used Sansa Fuze v2 (e280v2) and patched it from firmware 3.1.11e to latest available Firmware for Sansa Fuze 3.1.16e from the SanDisk support forum

After successfully upgrading the Fuze v2 firmware, I try using the RockboxUtility-v1.5.1 to install the Bootloader and Rockbox files. When asked I provide it with the same Sansa Firmware (e200pe.bin) which I successfully used for patching the device before. But the RockboxUtility refuse to use it with an error message:

--- Code: ---[ERR]  OF File provided is e200v2 version 3.01.16, not for Fuzev2
[ERR]  Could not load e200v203.01.16e/e200pe.bin

--- End code ---

After playing around with different firmware versions without success I switched to manual install, as described on the Again I first successfully upgraded the firmware using the downloaded file (e200pe.bin) and then issued the following command:

--- Code: ---$ ./mkamsboot e200v203.01.16e/e200pe.bin bootloader-fuzev2.sansa patched-e200v2-3.1.16e.bin
mkamsboot Version 1.5
This is free software; see the source for copying conditions.  There is NO

[ERR]  OF File provided is e200v2 version 3.01.16, not for Fuzev2
[ERR]  Could not load e200v203.01.16e/e200pe.bin

--- End code ---

As you can see I get the same error messages, when trying to patch the valid firmware.

I'm thankful for any suggestions, what else to try.

Error is pretty clear you are using firmware for different device:   "OF File provided is e200v2 version 3.01.16, not for Fuzev2"

Download manual for your device and follow installation instructions from there:

Link for proper firmware from manual above:

Reading through my own post below I realized, if I could flash the firmware named e200v2 maybe I could also create a boot loader based on the bootloader for e200v2 'bootloader-e200v2.sansa'. I gave it a try and it worked. mkamsboot created a patched boot loader and I could run it on the device.
So as a next step I then used the graphical RockboxUtility-v1.5.1 again, but this time I manually selected 'Sandisk Sansa e200v2 series (Stable)' as the device. I ignored the error message, started the installation, selected the same firmware 'e200v203.01.16e/e200pe.bin' and watched the installation proceed and finish like a charm.

Now I'm unsure if I own a 'e200v2' or 'e280v2' aka 'Sansa Fuze v2' but at the end I don't care about the name as long as it works. For reference I include a picture of the device with Rockbox running on it.

thanks for your hint @bahus

The fuze is actually a completely different series of mp3 players. What you have is an e200v2 series (evidently an e280v2), which is an older type of mp3 player that SanDisk made before launching the fuze series.

Thank you! I realize that now as well.
I acquired it as a "Sandisk Sansa Fuze" on eBay ;-)

And yes, on the back cover it has imprinted "model: e280v2". I was mislead to believe this might be just another name/version number for the Fuze v2.


[0] Message Index

[#] Next page

Go to full version