Installation / Removal > Rockbox Utility

No partition found error - looking for some further troubleshooting suggestions


Hello guys,

I'm currently trying to get Rockbox installed on an unmodified iPod Classic 7th gen 160gb.

Currently when I go to install Rockbox (from a fresh restore / format in iTunes) by using the RockboxUtility application, I encounter an error where after the step of putting my iPod in DFU mode, my screen says "Can't load rockbox.ipod: file not found". To bypass this, I am simply able to run the installer again, which causes my iPod to load past the Rockbox splashscreen, but then says: "No partition found. Insert USB cable and fix it."

I have also tried doing a fresh format with iTunes, and then installing only the Rockbox firmware first, and then the bootloader, which results in the same partition error.

Now, to be honest, I have very little knowledge of how partitions work, especially in the context of installing new firmware. If I were to take a guess, I would think that Rockbox is trying to locate a partition to be able to have the firmware be loaded from. I am not sure if I should possibly have a separate partition created than the firmware that my Apple firmware is loaded onto, though it seems that by default the installation process does not require users to have to create a separate partition. If someone could perhaps explain to me how the partition structure of a successful configuration for Rockbox on an iPod 7th gen would be, then that would be appreciated. (e.g. another thing I wasn't exactly sure about is if the rockbox bootloader should exist on a separate, much smaller partition. Understanding the partitioning aspect of how Rockbox works would be helpful for my ability to troubleshoot it).

Anyhow, I will be spending time this week to troubleshoot this further. I have read the manual's installation instructions, and have decided that I will try to do a manual installation process with Linux.

I also took a decent read around this forum about people that have encountered this same partition issue, and will have to spend more time reading since I found it difficult to quickly understand some stuff. I encountered emcore, driver inspection, and inspecting log information with commands which I could try once I spend some more time understanding everything. For now, I figured I would create a thread to get some starting tips or suggestions for things to look into / consider.


I should also add, that my iPod does work successfully with the stock firmware, I can load songs onto it and they play properly without issues.


I'm only commenting on the grounds of having installed RB a zillion times (usually on flash modded iPods, which seem to be far more prone to problems than the stock disk that you are using) and that am sure I've encountered some of the issues you report.  Not really an expert, though.

When you say the player says
"Can't load rockbox.ipod: file not found"

Is that not the message you get on the player when you've installed the bootloader but not RB itself yet?  Does it also say something about entering USB mode?

Is it what comes up when the thing reboots after DFU mode?  What does RBUtility say at that point?  Does it  report DFU mode detected and proceed to transfer the bootloader and does it then report the thing has rebooted and then transfer RB itself?  Be useful to know how far RBUtility gets in the process.

Have you tried forcibly rebooting the ipod (while it's still connected and while RBUtility is still running, after the DFU stage) into original firmware mode? (centre-menu to reboot, then holding menu down to force it into OF mode).

Also you are certain you are picking the right type of device in the list when installing RB?

The second error "no partition found" seems more alarming.  I've actually encountered that one a few times recently as well, but for me that seemed to be a flash-mod-related glitch, which seemed to be due to certain combinations of brands and capacities of memory cards not working together in the same device, but only for RB not the original firmware (solved it by rearranging cards between players).

If you are having these problems on the stock hard-drive it does make me wonder if there could be bad sectors on the drive.  It might not show up easily in the OF, if it's only certain areas of the drive that are failing.


[0] Message Index

Go to full version