Installation / Removal > Rockbox Utility

Sansa Clip+ after remove Rockbox and New Firmware: FAT is Corrupted


Hi there,

i using Rockbox with my Sansa Clip+ many many years. Last Rockbox 3.14 was installed.
After not using my device for 2 years, i charged and started it, but rockbox simply got stuck on startup. The device was no longer recognised on the computer, or only as an empty drive, rockbox utility couldn't find it either. By using dualboot (home + power for a few seconds), i was able to start the original firmware from sandisk. I made a factory reset and removed the remains of rockbox with rockbox utility. Then I installed the latest firmware from sandisk 1.02.18 and rebooted. After reboot i got the message: FAT is corrupted. The clip+ is no longer recognised as a sandisk on the pc, only as a drive without content,  amazingly as 2 drives. Rockbox utility can't find it either. What happened? how can I repair this? Thanks for help.

See if you can reformat the disk, but if not probably the flash memory died.  That would explain why both firmwares died together and why reflashing the stock firmware isn't helping.

My Clip+ is running again.

First i tried RMPrepUSB Tool, but it was only frozing, Sansa wasn´t found.

Then i tried this Fixit:

After reboot computer, the Sansa device was found quick without frozing on RMPrepUSB Tool and could use it:

Very happy.


[0] Message Index

Go to full version