Installation / Removal > Rockbox Utility

Trouble running Rockbox Utility on MacOS



I am having an issue setting up rock box on my 6th genereation ipod classic. I have a mac book pro running MacOS Monterey and every time i open the installer i receive this message "“RockboxUtility” cannot be opened because the developer cannot be verified.".

Does anyone know how i can get around this!



I run the installer in a Terminal window using sudo:

sudo /Applications/


--- Quote from: philden on February 25, 2023, 01:01:02 AM ---I run the installer in a Terminal window using sudo:

--- End quote ---

You usually don't need to do that. You need to run as root if (1) you're installing the bootloader and (2) installing the bootloader on one of those devices that require direct access to the hardware. That includes the older (not sure about the 6G, since that uses a different method) Ipods. Blindly runnig things with sudo is common, but often ill-advised.

You can right click the application, then "run", and then you'll get a message box that complains about the same thing as before. However, now it has a button that allows you to run it anyway. (At least that worked with OSX 10, my hardware is too old to run newer versions so I don't know if that changed; Apple makes it harder every time to do software stuff "the old way")

In the future, please use a descriptive topic title. Bad topic titles tend to get ignored. "Trouble setting up" gives no clue what your post is about -- "Trouble running Rockbox Utility on MacOS" is much better.

Hey, Ill make sure to make the subject more descriptive next time.

Even when i try right clicking or through finder i am still experiencing the same issue. I know macs sometimes give you the option to run anyway sometimes but i have yet to see that appear.



Ok so somehow it allowed me to bypass that wall. I started downloading rockbox onto the ipod and now my ipod is in recovery mode. Not sure if i messed up a step or how to recover.
The ipod turned off and Ive had no sign of life from it. The computer still recognizes it as an ipod when connected with a cable. I am asked if i want to download the software and recover the ipod.

any help is greatly appreciated


[0] Message Index

Go to full version