Support and General Use > Audio Playback, Database and Playlists

Device hangs while trying to update the database

(1/2) > >>

Hifi Walker H2
Rockbox AIGO EROS Q / K

Since the dev build from January 27th my device hangs when I try to update the database. I waited for more than 15 minutes. Only a shutdown is possible.
The database initialization works like expected, after deleting all "database_" files on my device.

I went back to the dev build from January 26th (last changes from January 24th) and the datebase update worked.

The changelog from January 27th is here:

Could these changes have something to do with these effects?

It sure seems possible that it could be related - there do seem to be a couple quick fixes there around midnight when the nightly builds would've happened though. Could you try it with the latest dev build and see if it's reproducible there?

For what it's worth, I just tried it here and the database update worked as expected. I'm on the native port, but I would think this isn't device- or port-specific.

Also, about how large of a library is this?

I haven't noticed any issues with those patches having updated my db 2 or 3 times since but I did see an area I need to look at here:

I think i need to add a lseek when skipping the tag data

Does updating work after you reinitialized the db?

Also if you goto debug>database info you should be able to see the progress of the update now (it doesn't auto update often so scroll up and down to redraw faster) that should give you an idea of how fast its moving

Yes, it's the same with the dev build from January 3rd. And no, updating doesn't work after reinitializing the db neither. I have  ~6200 files in my database.
And while it hangs on updating I can't do any actions, just a reboot. So I can't have a look into debug>database to see the progress, because I can't get there.


[0] Message Index

[#] Next page

Go to full version