Installation / Removal > Iriver - Installation/Removal/Flashing

Iriver H100 works with 3.11 build, but does not work with anything newer



I have an IRiver H100 that is fairly stable using an old 3.11 build, however, if I upgrade to any of the latest builds, whether it be the Stable 3.15, the daily build, or the development build, I run into issues with it freezing at the loading screen.

Somethings about my H100, I currently am using it with a 128gb SD card into a Compact flash adapter to IDE adapter, something that has worked on my previously and now lost Iriver H320.

To eliminate the if the 128gb SD card is the issue, I also tried putting back one of my spare hard drives to see if I could load the latest build onto it and I get the same issue occurring.

I don't mind using the 3.11 build, but I would like to upgrade to the newest version if I can. Just stumped as to why my H100 has this issue. I had an H120, that had no issues running the latest build. It is just suffering from USB mode on without a usb cable and I cannot get to work. (

You could find the latest working build with bisect and find the code change that made Rockbox not work on your player. Have a look at the development guide how to use this.


[0] Message Index

Go to full version