Installation / Removal > Rockbox Utility

IPod 7th gen install fail

(1/3) > >>

Hi everyone!
I bought a 160GB thin iPod classic recently. When I checked it out, I noticed it said 0kb available and 0kb used from the HDD space, and it completely reset after every restart, not seeing any files that were on the drive either (my Linux machine did see the songs through gtkpod though).
After failing to get the original software to behave, I decided to go for Rockbox. The installer got to the DFU part, detected the DFU mode, but right after it said it could detect no DFU device. From what I could find on the forums this could be solved by root privileges, but the issue is that I can no longer turn the iPod on. I read that setting the hold switch to off and then holding MENU+ACTION should rebboot, but it doesn't seem to work.
Could anyone tell me, if this is just already faulty hardware finally giving up, or if this has anything to do with Rockbox? Any ideas if this is salvageable?
Thanks in advance!

I would guess you have a dying hard drive. Time to replace it with iFlash and some microSD cards and expand the capacity.

So it is sorted out now, but I'll leave the solution here for the future generations.
The iPod was hard stuck in DFU mode for some reason, but I managed to restore it using a friends MacBook.
The device seems fine now, all the earlier issues are now gone (my guess is it was a misformatted HDD).
I'm gonna retry Rockbox install later today, but this specific issue is cleared up now.

I'd still suspect philden might be correct.  Could be bad sectors on the drive and at some point - when you write to that part of the drive - it will go wrong again.

I ran the built in HDD diagnostics, and it said there are no moved sectors. How reliable is that?


[0] Message Index

[#] Next page

Go to full version