Installation / Removal > Rockbox Utility

Please help me understand this error ipod classic 120gb gen 7


I just recently discovered rockbox and I'm hoping it can help with my ipod classic 120gb gen 7 issue I'm having with my Ram 1500 uconnect 5.x. I guess apple no longer supports the api for the classic so ram dropped it.

I've tried the auto installation several times on linux mint and windows 10. always the same error. I did go into itunes and reset the ipod to factory image. I'm using the original cables that I've had when I bought the ipod.

Please take a look a the attached image, this is the error that always comes up. I have not been successful in my searches in google for DFU errors. I actually don't know what DFU means.

Can you please help understand this error and maybe to get rockbox installed.


DFU is the Device Firmware Upgrade device class in USB. A lot of modern controllers with USB support can use it to receive firmware updates these days. Google for "usb dfu" for more info.

On the Ipods (only applies to 6G / 7G) enabling DFU mode is time sensitive, you need to press several buttons at the correct time. I'm assuming you didn't get the timing right. The manual has more information on this, especially this link.

Thanks you bluebrother,
ya it's a little confusing, I'll try again, the video doesn't show the hold switch sequence but I'm assuming I do step 1 right after the installer tells me to to hold MENU and CENTER. Fingers crossed.

an Update...
Nothing I tried in the auto install part of the document worked. even tho I could see the DFU device appear using the mks5lboot utility, the setup still fails with the same as the image I attached.
So I tried the manual installation, this is in linux mint 20.3
I followed the manual instructions of my specific device pdf file very closely and I was able to get the firmware on the ipod, but the rockboxutility still failed to transfer the rockbox software.
I rebooted a few times and still it would sit at the attached screen shot. I felt stuck, I tried to remove the new fw using whatever method I could find and could not!

the problem now is the ipod was in read only mode so I couldn't transfer the zip file
I booted into my windows box and tried that manual setup, and it still failed in the same was as the images show.

At some point while rebooting and reconnecting, I was able to write to it in windows so I transferred the .rockbox over to the ipod.
I didn't write down what I was doing at this point as I had pretty much given up.
At some point I rebooted and voila, rockbox booted up and I could see the interface.

Needless to say I am a happy camper. But I am a little sadistic in that I want to repeat this whole process so I can understand what worked and what didn't work. I know it's crazy.

What steps do I need to do to restore the ipod to be an apple device? so I can repeat this whole thing?

Many Thanks


[0] Message Index

Go to full version