Installation / Removal > Other - Installation/Removal

Surfans F20 "NAND open error"

<< < (11/11)

That is awesome, thank you very much.  It worked, I was able to get the flash dump (attached), and the flash_onfi_info:

signature = 03040506
revision = 5502
manufacturer = ""
device model = ""
JEDEC mf. id = 00
data bytes per page = 0
spare bytes per page = 0
pages per block = 0
blocks per lun = 0
number of luns = 0
bits per cell = 0
max bad blocks = 0
block endurance = 0
programs per page = 0
page program time = 0
block erase time = 0
page read time = 0

The dumped ROM looks reasonable to me.  From your description on the wiki, the SPL header looks good.  The partition table looks different from your example but it doesn't appear corrupted. I ought to be more familiar than I am with MIPS assembly language, as I've been working on this N64 emulator for many years (though not recently).  The reverse engineering that you and other RockBox devs have done with these little music players is really impressive.

Let me know if you agree that the dump looks good and I'll attempt to flash it with the boot room you gave above.

Looks good to me. Should be safe to flash that bootloader.

The ONFI dump didn't work but that's not a problem - it has no use except debugging.

The partition table looks like an expanded version that includes a list of supported flash chips. Maybe it's worth tracking them down and adding support ahead of time.

Alright, I flashed the boot loader and it works! Thanks; you saved me from returning this player to Amazon. The RockBox player has no problems with the 512GB card and boots faster. This is a very cool project.

Some bad news and some good: had to go back from the native port to the hosted because the native was unstable (it would regularly stop playing, display "unkwn artist" "unkwn track" instead of the correct file, and I think also corrupt files on the SD card (at least, after it had crashed on a file it would then likely crash again on that same file)). I was otherwise happy with the native port because it didn't have the issue I have with the hosted port, where loading the file browser for the first time after boot takes about 10 seconds (I think this is related to using a 80% full 512gb sd card).
So I did a clean install of the hosted port with the latest 2.7 pre-patched image from the wiki, and now line out works! Many thanks to all who worked on supporting the v2.7 players.


[0] Message Index

[*] Previous page

Go to full version