Installation / Removal > Other - Installation/Removal

Surfans F20 "NAND open error"

<< < (10/11) > >>

I've made a new bootloader release which includes the changes in the "v7" bootloader. Now both old and new Surfans/Hifiwalker variants are supported by the same bootloader.

The new version is linked on the wiki, or download here.

Getting a 404 on that link.

Thanks, the links are fixed now.

Hello all. I just bought a Surfans F20 on amazon and a 512GB sandisk ultra card to store my whole music collection to take on trips.  The default player is okay for me except I found that whenever I jump to another song it makes 2 very loud clicks in between the songs. That's not a very good feature for a "hi-fi" music player. I contacted Surfans tech support and they suggested it is a problem with the microsd card. I tested with the 32GB card that came with the player, and what do you know it doesn't make the clicks when switching between songs. So they're going to blame my 512GB card and say it's not compatible, but I'm a computer engineer and I understand that this card is really just uncovering some latent defect in their crappy software and it's not really incompatible.

So this is how I discovered RockBox. The OEM player says that it's version number is "2.3" which is interesting because this number is not mentioned anywhere in the RockBox documentation regarding the F20. I used the RockBox Utility software and tried to do a hosted installation, but the firmware update never worked. Each time I tried, it just switched between a black screen and the Surfans logo screen a couple of times and then booted back into the OEM player. I tried with the patched UPT files from the RockBox Utility program, and also with the unpatched UPT files for the F20 v2.2, v2.5, and v2.7 firmware files linked on the rockbox wiki, and none of them worked.

So then I went the native route. I can run the boot loader with the jztool program in USB boot mode, and I can run the rockbox software directly from the bootloader, so if I could flash the boot loader I think I would be good to go.  But whenever I try to make a backup of the OEM bootloader, I get the dreaded NAND open error.  Apparently the player that I bought has yet another different flash chip. Here is the output of the debug flash_info.txt that I get from the bootloader tool:

readID opcode  = FF E5 71 E5
readID address = E5 71 E5 71
readID dummy   = E5 71 E5 71
sfc params0  = 06 05 04 03
sfc params1  = 02 55 AA 55
sfc params2  = 00 44 02 02
sfc params3  = A4 2F 00 00

I tried the flash_onfi_info as well but that failed.  Can somebody help me get this working?

That's supposedly a Dosilicon DS35x1GAxxx. Test bootloader with support for it available here:

Try ONFI info & bootloader backup and post them here, I can sanity check them. If you're confident that it's working you can go ahead and do an install, but I'd advise taking a full flash dump beforehand (and make sure it looks reasonable...) in case things go wrong.

EDIT: I updated the wiki with some info on what the flash contents should look like. Should be helpful if you're inclined to check the dumps yourself.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version