Support and General Use > Audio Playback, Database and Playlists

(SOLVED) Strange behavior using iPod with iFlash adapter


I recently modded my iPod 5.5 with an iFlash adapter and a higher capacity battery. I installed rockbox without any issues and songs work fine regardless of what OS I copy them under. However there’s a strange issue I’ve encountered that I’d like to fix, if it’s possible. I can play music with a custom EQ and increased base/treble without any problems. Before I installed the iFlash I would also use the HAAS Surround, and it worked fine. But since upgrading to the iFlash, if I enable that feature rockbox becomes extremely laggy during playback, taking up to 45 seconds to register inputs, so it’s basically unusable. I’m wondering if this is an issue with the iFlash adapter, or if it could possibly be because I’m using the newest dev build now and the old drive was running the stable version? Any help resolving this would be much appreciated!

EDIT: It was an issue with the build of RockBox I was using. I switched back to the stable branch and everything works fine now. Thanks!

I don't know if the iflash uses more CPU in the driver, but the extremely slow CPU on the 5g means you can only have a limited number of DSP effects active at once.

Never mind, I fixed the problem. Turns out it was an issue with the version of RockBox I was using, I copied the files from my old install over and it works great!


[0] Message Index

Go to full version