Installation / Removal > Toshiba - Installation/Removal

Got my old F60 working.


I had a bricked F60 sitting for years, finally tried to fix it. Here's what worked.

Im running windows 10, 64 bit. I tried to install the original gigabeat room software and even in compatibility mode, the format utility didn't seem to work and the firmware file wasn't in the program file. I had an old PATA hard drive from my old computer. I accessed it from an external enclosure, connected to my Windows 10 laptop. I was able to run the format utility and upload the firmware file and it immediately worked.

I can send the file to others if need be. I'm trying to convert this to Rockbox now.

FYI the Gigabeat format utility is just a FAT32 formatter + adds the hidden folder with the firmware for the device.   You can just back the latter up somewhere and then use any FAT32 formatter you want, in the future.

I assume btw that you didn't get Gigaroom itself working in Windows 10?  To my knowledge it doesn't work for either Windows 10 x86 or x64...Rockbox of course is a different matter.


[0] Message Index

Go to full version