Support and General Use > Hardware

Ipod 4G grayscale: Not showing up as a USB device at all

(1/1)

othello7:
Hello everyone. I'm new to these forums, but I've been using Rockbox for about 2 years.
My Ipod 4G would always connect via USB to computers fine until recently when I plugged it into someone else's charger. Now it does not even show up in lsusb. Luckily, I can still move data to and from the Ipod because I have an iflash adapter with a 256GB sd card. now I've heard a lot of stories about flash adapters not working but mine has worked flawlessly in all the time that I've used it. Essentially what I've been doing is opening the Ipod and taking out the SD card every time I want to add music, videos, or custom plugins that I'm making to it. But a few days ago I think the ribbon cable came a little undone and the data got corrupted. I looked on the Rockbox pages for the replacement partition table and such but the problem is, there isn't a 256GB one lol. Even though I seem to have sort of gotten it fixed with ipodpatcher, it is giving me the folder icon with the apple support link. Aside from the data issues, it will also only charge with a very specific ipod dock (I think it has to do with firewire vs usb connections it just wont charge from 5V I think) I'm hoping this is a problem with the motherboard at this point instead of the $40 iflash adapter. Do you think that replacing the motherboard would solve my problems? Do you know any other way to reliably manually restore the ipod directly from the SD card? Thank you for your help

Navigation

[0] Message Index

Go to full version