Rockbox Development > Starting Development and Compiling

arm-elf-eabi-gcc not in path


I'm trying to compile another build of Rockbox for my Ipod classic again and it's been some time since I last did it, seems as though some things have been updated and I cannot seem to get arm-elf-eabi-gcc to install for the life of me, following this guide and don't seem to be helping me. and I've tried just about anything I can think of haha, probably something right under my nose.
I can find a folder for arm-elf-eabi but that doesn't show up when I try which arm-elf-eabi, thanks in advance!

Hey, this is also an issue for me if anyone else can report what they did to fix it. I tried running for another platform (m68k-elf) and it shows the location with no issue but for some reason it does not work here. I've tried using the outdated linked VM, windows linux subsystems, and now my own newly created Ubuntu VM. All 3 had the same issue so I have a feeling has some sort of bug (or the guide is missing an important step)

Does the compiler build successfully?  If so, you may need to add the compilation directory to the path:


[0] Message Index

Go to full version