Support and General Use > Hardware

IPOD Classic 7th Gen 160GB: USB device not recognised

(1/1)

CAFO:
Hi all,

Background:

I installed Rockbox on my Ipod Classic 7th gen around 5-7 years ago. I installed emcore r859 on the ipod, in order to run Rockbox (which is at version 12f5c... currently). I stopped using my ipod for serveral years, opting for my phone instead, until I got some new headphones and a bigger music library. I decided to revive my old ipod, and found it sounded better than my phone. Everything on the ipod works perfectly, including my old music library, except I couldn't get it to connect to either windows or my macbook. I assumed this was due to a hard drive issue, purchased an iflash board and an sd card, but found the issue still persisted. While the ipod booted into emcore and the rockbox fallback image fine on the new iflash board, it still wouldn't connect to my laptop.

The issue:

Any attempts at connecting to windows result in a USB device not recognised error (mac shows no recognition of the device at all). In device manager, this shows up as Unknown USB device (device descriptor request failed), aka code 43. I've tried connecting from Rockbox, from emcore, from UMSboot and from DFU mode, but all attempts result in the same error. I've tried updating the driver, disabling it, and more extensive methods. I've tried the method here: https://freemyipod.org/wiki/Restore_iPod_without_iTunes but fail at step 9 of the "Uploading the first restore stage." I'll also mention, I'm trying to connect the ipod with a third party cable. If there's no other option, I'll purchase an original cable.

Essentially, I'm looking for a way to connect what's essentially a perfectly operational ipod classic to a computer to transfer over new music. Any help is greatly appreciated.

CAFO:
Update: Bought an original apple cable and it works!

Navigation

[0] Message Index

Go to full version