Rockbox Development > Starting Development and Compiling woes

(1/2) > >>

hi all,

trying to get working on a new Linux build (Debian 10)

using the patch to allow for newer versions of gcc, rockboxdev successfully completed..

But when I run tools/configure, I get the warning "WARNING:. Your cross-compiler arm-elf-eabi-gcc 4.4.4 is not of the recommended version 4.9.4!   This may cause your build to fail since it may be a version that isn't functional or known to not be the best choice.  If you suffer from build problems, you know that this is a likely source for them.."

And sure enough, when I run "make zip" it stops along the way saying "/bin/sh: 1: arm-elf-eabi-gcc-ar: not found".

Appreciate any help that could be thrown my way.   My next idea would be to install an old Linux build so it's more of the era of the last update of but that's not super ideal

Which patch did you use? 

On the current master branch builds GCC 4.9.4. You shouldn't need to apply extra patches to 'update' the toolchain.

I used this patch:

The reason I used the patch was because was failing, I unfortunately no longer have the error , I think it was Error 2 (and some mention of arm-elf-eabi-gcc or gcc).

I'm not sure where to go from here, I suppose from the above replies I shouldn't have applied that patch?  How does one uninstall all the stuff did to start over?

It still leaves me with the problem that rockboxdev failed without the patch, so unsure what to do.  I used the version of that came with a new git pull.

Thanks again, to be clear I'm not particularly attached to Debian or anything, I am willing to do any OS or virtual box to get this to work, I have an old laptop which I am dedicating to this one purpose.

If you look at that link it explains that the patch was abandoned because the problem was already fixed back in 2016.

Revert that patch (or just revert your whole got checkout) and rerun See what fails and go from there. Often it is something simple like a missing library.


[0] Message Index

[#] Next page

Go to full version