Rockbox Development > New Ports

Shanling Q1

<< < (21/21)

Hi everyone! Thanks for this phenomenal port that I've been using happily for about six month until yesterday ... something broke. Without any further changes (not attached to a new computer, no charging, no manipulations to sdcard etc.), the Shanling Q1 refuses to start. It does show the bootloader and boots into OF. When asked to boot Rockbox, it shows the logo, very briefly shows the text scanning... or similar and shows the logo again. It stays in this state for about 15 seconds or so, dims the screen, later turns the screen off, finally shuts down after a few minutes. I tried:

* Check if the sdcard has bad blocks. Yes, it does (unsurprisingly), so I formatted it with mkfs.vfat -c in order to skip over bad blocks. No effect.
* Tried another sdcard. No effect.
* Tried another sdcard. No effect.
* Tried to reflash the bootloader. No effect.
* Tried to flash the original bootloader. Software refused, claiming it's not a tar archive (which is true).
* Update: Took the wrong file :-( it lets me flash the original bootloader (which works as expected) and flash Rockbox' bootloader (which boots OF properly and leaves Rockbox stuck).
Do you have any hints what else to try? Do you need any more information?


[0] Message Index

[*] Previous page

Go to full version