Support and General Use > User Interface and Voice

iPod nano 2g, hold switch isn't unlocking once locked but only in Rockbox

(1/2) > >>

In Rockbox the hold switch when pushed back to its normal position after locking isn't unlocking the keys.
In the normal apple firmware when I boot into that now it locks and unlocks perfectly, no issues, so it isn't that the switch is physically damaged.
When i lock in Rockbox the screen goes dark and then when i put the switch back the screen comes back on but the keys are still locked.
I mainly got the nano to play Doom, you need the lock switch to get to Doom's menu so this is a problem.
Also it does it during music playback, have to reboot the nano to get it to respond after locking.
I've installed Rockbox twice using the Installer and this has happened, even tried going from a stable install to the latest build but the problem persists.
Thanks in advance.

iPod nano 2g 8gb to be specific.

Tried some older firmwares with the same result, seems an odd bug to have.

Found an old post from 2008. Apparently you need to spin the scroll wheel a bit and press the centre button after unlocking. Insane that this never got fixed and the port is marked as stable! I love Rockbox but that's not great. Will see if I can remap Doom's buttons as pressing centre will launch a new game in the menu and there's no way to back up in the menu so you can't really use the menu at all.

Given up on it. You can change the in-game keys for Doom but has no impact on the menu keys so you can only select New Game when the keys start working again after using the hold button.

The patch that was uploaded at the end of last year should have (finally) fixed this issue - or at least a very similar one – for iPod 4Gs and 5Gs, but apparently not for Nanos then, if you've tried the latest dev releases.,21203.msg147950.html


[0] Message Index

[#] Next page

Go to full version