Support and General Use > Theming and Appearance Customization

Help with theming Layers/Buffers (Sansa Clip Zip)

(1/1)

mrjpaxton:
The Sansa Clip Zip sports (see what I did there) a 96x96 pure OLED screen with 64 mapped colors, which actually looks kinda nice in person! The colors and text are vibrant, sharp and retro-looking.

Anyway, I need some help with some theming issues. This is my current WPS (while-playing screen) file, for example in /.rockbox/wps/foobarxyz.wps


--- Code: ---# Album Art/Info Viewport Conditional
%?C<%Vd(a)|%Vd(b)>
#
# With Album Art
%Vl(a,15,0,-,-,-)
%Cl(0,10,64,64,c,c)
%Cd
%Vl(a,0,0,-,12,1)
%t(4)%s%ac%?it<%it|%fn>;%t(4)%s%ac%?ia<%ia|%?d(2)<%d(2)|%(root%)>>;%t(4)%s%ac%?iy<%iy|Unknown Year>;%t(4)%s%ac%?ig<%ig|Unknown Genre>;%t(4)%s%ac%fk kHz %fc;%t(4)%s%ac%fb kbps %fv
%Vl(a,0,72,-,12,1)
%s%ac%pc/%pt
#
# Without Album Art
%Vl(b,0,0,-,-,1)
%s%ac%?it<%it|%fn>
%s%ac%?ia<%ia|%?d(2)<%d(2)|%(root%)>>
%s%ac%?iy<%iy|Unknown Year>
%s%ac%?ig<%ig|Unknown Genre>
%s%ac%fk kHz %fc;%ac%fb kbps %fv
%pb(0,-,-,6,-,setting,%pc)
%s%ac%pc/%pt

--- End code ---

This minimal WPS theme works pretty great for me. It has separate settings for displaying album art if the audio file supports it, with alternating text, otherwise it displays text information line-by-line without alternating.

Except, there is one little problem. When there are these "pop-up notifications" that are larger than the album art, one of the drawing buffers doesn't clear the edges of it past the album art image when it's supposed to completely disappear, if that makes sense. This problem does not happen when there is no album art, I believe.

So in other words, fragments of the pop-up notification, depending on how large it is, are left behind. And it's a very annoying graphical problem.

I really have a hard time understanding how the drawing buffers of the Rockbox themes work. If anyone can help me fix this issue, I would greatly appreciate it, because I've tried a lot of solutions, but I can't seem to figure it out.

Thanks a lot!

Bilgus:
Is this working the same (improperly) in the latest dev versions?

I've fixed a lot of that with the image buffer update https://gerrit.rockbox.org/r/c/rockbox/+/2811

If this still occurs with the latest dev version please let me know (I probably missed a case)

mrjpaxton:

--- Quote from: Bilgus on December 31, 2020, 11:11:15 AM ---Is this working the same (improperly) in the latest dev versions?

I've fixed a lot of that with the image buffer update https://gerrit.rockbox.org/r/c/rockbox/+/2811

If this still occurs with the latest dev version please let me know (I probably missed a case)

--- End quote ---

Oh, shoot! I forgot how I tested it. Hmm.... It's been a while ago since I've updated the ".rockbox" folder, but yes, I am going to try the nightly builds.

I've downloaded this one here: https://git.rockbox.org/cgit/rockbox.git/commit/?id=10e2f53ff5 - And I'll test it.

I do want to personally thank you for your work on the project! I will try it out for a few days, or see if I can get one of those messages to popup again, and get back to ya.

mrjpaxton:
Ah great, it looks like it's fixed!

I just forgot how to test it. I test it by locking the buttons, which shows the elongated "Buttons Locked" message. On the Sansa Clip Zip it is Home+Select.

I guess this thread can be locked now. :)

Navigation

[0] Message Index

Go to full version