Rockbox Development > New Ports


<< < (52/52)

I can confirm the Eros Q outputs music to external DAC connected to USB (confirmed by Samsung/TempoTec dongles).
I bought it just for the USB out and... it works (very happy). (yes, took the risk and it paid off).
Playing from 512GB card, so far it's fine. It makes it extremely underspecced player.
Now i can let my iRiver iHP120 rest (used it for digital output).

Flashed RockBox 1.8 prepatched FW, the player hangs with the 512GB card:
 - Bootloader is fine, select RB -> hang. If i go to utilities, exit and run RB -> boots, try to browse files = hang. eject card = FW unfreezes.
 - Selecting OG firmware, hangs on boot. Eject the card - FW unhangs, insert the card - works ok.

The player came with 1.9v firmware, can't find it anywhere now, but there is 2.0 on the official website which doesn't hang on my (and doesn't seem to be supported by the patcher as the RockBox utility crashes during(before) the patch process).

Does anyone use 512gb cards? I wonder if it's size or exFAT issue. the card is FAT32
I'd guess the native build won't support usb host DACs.
Is there any patching manual/hints on unpacking/modifications for the original FW other than bin patches?)
./ eros_q fw.upt bootloader.erosq
+ install the packages:
# need '7z', 'mkisofs', 'md5sum', 'mkfs.ubifs'
# and

had to run the command with sudo as the script got some permission errors, then the resulting FW bricked the player so i've added another "fix" to the script that "fixed" the internal FW file's permissions:
system("chown -R 777 /tmp/");
### Generate new RootFS UBI image

UPD2: Patched the 2.0 FW with the bootloader, RockBox works, but no USB output, :(
My best chance would be tapping i2s lines from DAC and converting them to LVDS, or adding SPDIF transmitter, both options rely on player's internal clocks and their jitter would be not great.

Unbricking procedure: add original update.upt in the root of card, turn off, turn on by pressing pwr+vol up => it loads the FW from card.

Tried to play with /etc/asound.conf, managed to select the default output card/device, and... and silence. Yet, when i unplug the USB DAC, RB hangs. It means it is playing thru USB, or at least uses USB clock for playback. Attempted to run amixer before rockbox load gave no results (i have no idea what i'm doing).
So... debug build it is, wish me luck :)

UPD4: no luck. Built, got debug thru printf() to stdout >> fille.log (LOGF didn't worked for me), and then ubuntu VM gave up on building in SW volume control mode (less ALSA involvement). maybe there is some specific codec code, dunno, it got too involved for this time.

By the way, ALSA reports ES9018, which is nice.


[0] Message Index

[*] Previous page

Go to full version