Third Party > Repairing and Upgrading Rockbox Capable Players

Trouble attempting repairs on a bricked Sansa e270


Hello everyone. A while ago I bought an e270 that was bricked off eBay. Today it arrived, but what I thought was something I could fix easily via recovery turned out to be far more difficult than I had expected. I was following the advice on another thread( and also got stuck on trying to execute e200tool. I tried the modified e200tool after that, still no dice. I double-checked that everything was correctly spelled. I also tried pressing on the memory board as advised in that thread and didn't get a click. I'm stumped as to what the problem could be at this point. Help would be much appreciated! Thank you!

Do you have libusb installed?  You may also need libusb-dev as well.

Thanks - I'll try that when I get home from work and will update you when I do.

Update: Yep, I was able to continue through the process after installing libusb-dev. It's now revived and Rockbox'd! Thank you for the help, as many of us aren't Linux users!


[0] Message Index

Go to full version