Third Party > Repairing and Upgrading Rockbox Capable Players

Two old sansas

(1/1)

ljones:

Two old sansas sitting on a wall,
two old sansas sitting on a wall;
but if one old sansa should accidentally fall;
there'll be one old sansa sitting on the wall.


Ok I know that isn't the best way to open a question but I couldn't think of much else off the top of my head. But I have a question about trying to repair a couple of old sansas - they are V1 Sansa E280s. Neither of them work properly, they're pretty much antiques these days and not worth a whole lot and they are just lying around. So I thought it might be worth giving them a go and seeing if they can be fixed after all there's not a whole lot to loose.

Both sansas are the same (E280,V1) and unfortunatly do not work. The first sansa was an ebay find I bought ( I cannot recall exactly how long ago ) a few years back and was working up until recently. Now though all I am getting is a completely white screen, no other text just a white screen. Other operations so far as I can tell seem to be normal; the blue ring lights up if you move it and will go off after a time. I can hold down power normally and power off; if I plug the sansa into a PC it is listed as a Sansa E280 device. So it looks like it is going through the motions but just not displaying correctly on screen. Does anyone know what the problem of the white screen would be? (The screen is permanently completely white, nothing else until power off).

The second sansa is older and again I forget exactly when I bought it (probably roughly a decade ago). This sansa E280 seems to be in a much worse state than the other sansa. The blue ring will remain on at power on (manufacturing mode?) but on this sansa I never get any display on the screen. This one nothing is displayed on screen ever. I have tried the rockbox instructions on how to de-brick the sansa E200 devices but to no avail.

I can run e200tool for this device (E280) but to no avail. For example I can run e200tool recover  BL_SD_boardSupportSD.rom as suggested in the instructions; the PC will find the sansa and attempt to flash/run the .rom file (as per the instructions I'm also holding down the record button). The sansa seems to reset (the blue ring goes off and comes on again) but no 16MB partition ever shows up. I can even get e200tool to reflash the i2c but still no joy. I'm guessing partly this could be down to not having the correct firmware (bin/mi4/rom files) for the device. From memory the device is an EU (not a US, I'm in the UK) device with an FM radio but I don't have the correct files. For eample the e200tool website lists i2c-e280.bin but this is for a US sansa.This page on the same site lists several devices and files but none match my device.

Does anyone know what might be wrong with this sansa at all and the other sansa at all? I'm tempted to say they are both hardware failures - the first sansa maybe either a dead screen or cable; the second I'm really not so sure. I do remember what I was doing on the second sansa before it died however; I was looking at a .jpg file on the sansa - it then immediately shut down and has never come back on properly.

Am thinking of trying to take them both to bits and to see if I can make "one out of two" but given they're both broken I wonder if that will work at all.

ljones

johnb:
Hi ljones,

similar story here: I got two Sansa e250/e280 v1 from Ebay marked as defect with blue ring of death.

The first one I revived with the unbrick methods described in the Wiki, but the screen was white all the time. This one I use in "blind mode", i.e. with voice active and display turned off. I can zip the .rockbox directory incl. config.cfg and send it if you like.

The second one was tougher until I found out that the EU firmware has a version with and without radio.
Using the "without radio" finally succeeded.
I can send you the two firmwares to try, just PM me.

Only drawback: on both players the SD slot is not working, i.e. no card is detected.

ljones:
Pretty much I think the second sansa (with nothing at all on the screen) has an FM radio; the first one might but I can't remember.

ljones

ljones:
I got your files ok, many thanks. Alas no joy on making a Sansa lazarus x.x !

I've not yet tried sansa one but the second sansa still remains as it was; it'll accept the rom image, restart but remains with a blank screen and the blue ring permanently on - no partition appears. Maybe I still have the wrong or broken I2C image? (I've tried reflashing that -- it'll flash and verify ok but no difference).

At this stage in the game I'm tempted to try the old trick of "making one out of two"  - namely take the two sansas apart and using working parts from 1 and 2 see if I can make a complete sansa. I'm not sure how the screen is attached to the main circuit board but one thing to try (and from memory) the memory board in the sansa can be removed so eventually I hope to try to swap over each sansas' memory board and see if that changes anything.

ljones

Navigation

[0] Message Index

Go to full version