Rockbox General > Rockbox General Discussion

Rockbox on Clip Zip hang on particular micro sd

(1/2) > >>

Hello everybody,
I've got a Sansa Clip zip since a long time now and it still works as a charm.
I updated to last Rockbox 3.15 with success.
I recently bought 3 Sandisk 64gb SDXC, all 3 are exactly the same.
I formated them in FAT32 with Gparted on Unbuntu 18.
Two of them works ok with Rockbox, they are full of various audio format (APE, FLAC, MP3).
But the third makes me really mad. Indeed, whatever file I want to play makes Rockbox unstable. Much of the time the file seems to be played but there is no sound. If I want to stop, it continues to plays. If I want to shut-down my clip zip, I have to push stop button for almost 30 sec before it really shut down. Sometimes, it freeze completly.
I tried to format the card several time (always FAT32), with several tool even with Windows too. All the files on this particular card are playable without any problem under Linux, Windows and even an Android phone.
I verified the card and it hasn't any error. If I plug my Clip zip on usb with this card into it, all files are accessible from the host without any problem and can be played .
Very crazy.
Your help would be really appreciated !
Thanks a lot in advance,


I tried something again: complet format in exFat, then in Fat32...
Copy some audio file, play, can't stop... Try to shut-down, the it a white screen appear:
allback() - Could not write sector 640962
(error -24)
pc:30078a28 sp:3bt end

Finally I've got it !
First I did a low level formatting with HDD LLF Low Level Format Tool
and format again in FAT32.
In fact I followed most of,51941.msg240386.html#msg240386

almost one week later, the same card have the same issue... And I didn't use it since last time !
However, I found new strange behaviour.
I remarked that this card have this issue on all the songs when the battery is almost empty.
When the battery is full, only a few song has this issue. I don't know exactly how many, and wich format are affected.
When a particular song presents this issue, and if I can shut down the clip zip, then if I plug the charger, and try to play again the "problematic" song, it is then playable !
If I unplug the charger when this song is played, it continues without issue... If I then shutdown and restart, the song isn't playable.
Crazy isn't it ? So, what's wrong with it?
Can you help me ?
Thanks in advance.

To moderator,
sorry, but I think I posted this subject in the wrong forum. Can you move it to "hardware" please ?
I think it would be judicious.
Thanks in advance.


[0] Message Index

[#] Next page

Go to full version