Third Party > Repairing and Upgrading Rockbox Capable Players

Sansa Clip+: dead after "chkdsk /f" abort

(1/1)

johnb:
I recently bought a SanDisk Clip+ 4GB on *bay.

It turned on, I could copy some existing music from the player to my PC (still using the OF).

Here comes my mistake:
Before installing RB, I thought of checking the internal flash and ran (being on Windows) "ckkdsk /f D:".
It reported illegal crossreferences and started to repair them, but then seemed to get stuck. I finally disconnected the player and forced Power Off.


Ever since, it won't turn on anymore:
Screen stays black, connecting USB nothing shows up on windows.
I have tried "longpress power button" for almost 1 minute. I have tried holding the middle button while connecting to usb: to no avail.

I hear no popping sound while inserting the headphone. However, when it is inserted and I click the power button (just very briefly, not like longpress for turning it off), I can hear a popping noise, but just for a couple of trials.

I have waited for the battery to drain with the phones connected for several days.


Next thing I thought of was opening the case and disconnect the battery ...

Does anybody have further advice before I do that?

Chronon:
Probably worthwhile to consult here https://www.rockbox.org/wiki/SansaAMS#Unbricking.

If you can get it to boot (show the boot logo) then you should be able to follow the instructions at: https://www.rockbox.org/wiki/SansaAMS#Formatting_a_Player_that_cannot_get_past_the_Database_Refresh_in_the_OF.

johnb:
Thanks, Chronon.
I must have seen this page a dozen times before, but now that I needed it, it didn't come to my mind.

I succeeded in writing an image that bilgus had provided earlier with the bootloader that can boot from SD.
I never managee to boot from the internal flash again, but from SD worked fine!

Navigation

[0] Message Index

Go to full version