Support and General Use > Hardware

Clip+ potentially dead... but recognized by PC?

(1/2) > >>

My trusty Sansa Clip+ with latest Rockbox has served me well for about a decade, but it seems like it's about to die.

The battery life has been depleting over the past couple of years but I had no serious issues. However, today, out of the blue, I tried to turn it on and it just wouldn't.
There's nothing on the screen, no sound etc. No indication it's alive at all.

I've tried resetting it by pressing the power button for 30+ secs, and I've also tried power+select button for a while too - no luck. I've also tried charging it but nothing changes.

However, when I plugged it into my Windows 10 laptop as part of a desperate attempt to bring it back to life, Windows  seemed to recognise it - to an extent. I get a popup saying "You need to format the disk in drive H: before you can use it." My clip+ screen is still off, but I thought this might be an indication it's not completely dead yet.

Does anyone have any ideas about how to proceed and if the device is salvageable? I'm kicking myself for not buying a backup device back when they weren't super expensive.

Does it actually mount the disk?  If not, probably dead flash.

no matter what don't let windows format it


--- Quote from: saratoga on November 18, 2019, 09:13:19 PM ---Does it actually mount the disk?  If not, probably dead flash.

--- End quote ---

It shows me a new drive but it's not accessible.

--- Quote from: Bilgus on November 18, 2019, 10:34:24 PM ---no matter what don't let windows format it

--- End quote ---

To be honest, I tried out of desperation as nothing else seems to work at all, but I got an error saying that format couldn't be completed and it may be a read-only drive.

Windows does not have the tools to recover these devices they may exist but..
Linux has the tools to do it (dd & lsblk) but if its already readonly then the flash is dead and I've yet to see one able to be fixed once the flash has died
No one has been able to replace the flash chip and get it to work either, unfortunately

By default new installs to the clip+, clipzip, fuze v2 & fuze+ now have the multiboot bootloader
The latest dev versions of 3.15 firmware now have the capability to run RB from the sd card (with the multiboot bootloader)
Install both and stop putting files on the internal flash this will increase the life of your device


[0] Message Index

[#] Next page

Go to full version