Third Party > Repairing and Upgrading Rockbox Capable Players

IPOD (ALL MODELS) iFlash Adapter Issues

<< < (3/3)


--- Quote from: lisu on April 23, 2021, 07:53:24 PM ---
--- Quote from: MikeyDee on August 14, 2020, 01:57:24 PM ---I have a similar issue with my 1Tb iPod 6 classic, iFlash adapter .

I install firmware  no issues, I install Rockbox no issues,
Load up my Ipod ( over 600Gb ).

some time ( weeks ) later i want o add more songs, so plugged in my iPod, and Boom,
Screen flashes, and said " No Partitions Found.

I can fix by using a partition amnager ( AOMEI ) remove all partitions, create new partition ( fat32 ) .
Reinstall rockbox, reload my tunes.

This has now happened 3 times,

am now testing latest build , as per advise here.
Will report back.

--- End quote ---

I have similar problem. I have  also managed to reproduce it.
The 'no partition' bug strikes exactly when you plug turned off ipod with hold switch to on into computer.
I also have ipod 6gen with quad iflash adapter.

Does anyone know how to fix this issue?
Beside that rockbox works like a charm. But I\m bit scared to use my ipod since one day i can forget myself and lose music collection (or hours on restoring it) just by plugin ipod to my laptop

--- End quote ---

You mean you accidentally booted the Apple firmware and it corrupted your flash storage? One simple solution would be to use mks5lboot to install rockbox without dual boot. Since it sounds like the apple firmware doesn't work for you anyway, no real loss.

Thanks for Your reply.
I thought so, but i only managed to run 1TB using rockboxUtility.
I mean, since 6gen only allows to have 127GB after bl installation I need to repartition the device and reinstall rockbox.
But when i try to do the same manually

--- Code: ---./mks5lboot.x86_64 --single --bl-inst ./bootloader-ipod6g.ipod
--- End code ---
rockbox won't boot cause of 'no partition found' error.

Is there a way to set single boot installation on RockboxUtility?
I really know nothing about the project code but maybe i can recompile it if You show me where to set the proper flag or something.


I looks like manual bootloader installation changed my partitions back to apple defaults 64MB/127GB/(930GB Unallocated)

EDIT #2:

OK. It works.
I have deleted partitions created by single boot installation and created 1 big partition. After rockbox reinstallation
all runs great. When ipod  with hold switch is plugged i'm getting red message on screen what denotes that single bootloader is installed

Thank You again.

For the benefit of posterity, I tried everything in this thread on my iPod 4th gen (monochrome) with iFlash ATA1, to no avail.

The culprit turned out to be the SD card. I first tried a 128gb PNY UHS-I and then a 32gb Sandisk Extreme Plus U3. The winning combo, which is fully functional in Rockbox and original firmware, is the following:

iPod 4th Generation ClickWheel (20gb version, model A1059)
iFlash ATA1
256gb Samsung EVO Plus + Adapter MB-MC256KA

Hopefully this will help someone else make an informed decision in the future.


[0] Message Index

[*] Previous page

Go to full version