Support and General Use > Hardware

IPOD (ALL MODELS) iFlash Adapter Issues [SOLVED!?]

<< < (18/18)

I tried the latest dev firmware in my olde iPod 3rd Gen--the one where the controls light up,I don't recall the model number-- with (I think) the same green pcb, black connector Chinese-junk IDE-to-CF adapter with Sandisk 128GB (in SD adapter) and it works! Built a large database, played a few songs...seems fine. I might look into fixing up this iPod now with a new battery and replace the failing screen.

So to summarize my test results (all using Sandisk 128GB uSD, except iPod 5G which has a now rare Sandisk 128GB CF):
iPod Photo with "Super Talent"  1.8" SSD works, which is no surprise.
iPod 4G greyscale with el cheapo chinese green board IDE-CF doesn't work.
iPod 5G Video works with Tarkan iFlash CF (I bought it a long time ago, when CF was still easier to get.)

iPod 3G works with (I think) the same Chinese green board IDE-CF that didn't work in 4G greyscale.
Edit: (10/3/2022): there is still something wrong as rockbox started rebooting constantly on my ipod 3G. I'm guessing something got corrupted in the .rockbox folder. There is no error message.

I'm all outta iPods to test. btw, I didn't bother to test my iPod minis which all work fine with rb 3.15. Is there any big benefit to upgrade the mini to latest bleeding edge?

FWIW, I had constant freezing/panics on my flash modded 3rd Gen.
I made the following changes in /firmware/export/config/ipod3g.h and then built from source:

--- Code: ---Before: #define HAVE_DISK_STORAGE
After:  #define HAVE_FLASH_STORAGE

Before: #define HAVE_ATA_POWER_OFF
After:  //#define HAVE_ATA_POWER_OFF

--- End code ---

It's been trouble-free ever since. I can attach my built zip for someone else with a 3rd Gen if that's allowed.
Edit: Attached, hope it helps someone.
iPod 3G Flash:
(By request, untested) iPod Mini 2G Flash:

@jasonwray its allowed -- encouraged even

Is this actually fixed in the latest Dev builds?

I'm still getting track corruption after installing the latest Dev version using the Rockbox utility (installed release only, left the bootloader untouched from the previous release build).

Do I need to do a full clean install or is the issue still open?

Using an iPod 5G Video with iFlash Solo 128GB

No issues when adding files via OFW

For the benefit of posterity, I tried everything in this thread on my iPod 4th gen (monochrome) with iFlash ATA1, to no avail.

The culprit turned out to be the SD card. I first tried a 128gb PNY UHS-I and then a 32gb Sandisk Extreme Plus U3. The winning combo, which is fully functional in Rockbox (daily build) and original firmware, is the following:

iPod 4th Generation ClickWheel (20gb version, model A1059)
iFlash ATA1
256gb Samsung EVO Plus + Adapter MB-MC256KA

Hopefully this will help someone else make an informed decision in the future.


[0] Message Index

[*] Previous page

Go to full version