Support and General Use > Hardware

IPOD (ALL MODELS) iFlash Adapter Issues [SOLVED!?]

<< < (17/20) > >>


I bought iFlash quad back in 2018 for my ipod 5th. Tried RB, not worked (freezing, skipping tracks) - possibly due to RB issues with flash memory.

Now I found these updates so I gave it a go again. I picked the dev build, and daily build. Main question - are the Speachy's changes incorporated in the daily/dev builds?
I thought yes, so I tried them both.
I formatted the drive to fat32 in Aomei partition sw. Restored ipod in itunes. It seems working in the OF, even showing the disc size corretly (even when I had 2x256).
Then I installed RB (daily and second time the dev build). I installed it with itunes/ipod processes killed and in normal OF mode (connnected to Win pc), not the Apple disc mode (could be issue?).
I did put there the music right after instal, just a few gigs .

It shows slightly different glitches: I am able to play one album, but navigating more and putting more tracks to the "on the go" playlist causes freezes. The music usually plays but the display is frozen and the buttons are not doing anything.
So I thought maybe the micro sd cards are causing problem. I took off both Samsung Evo plus 256gig, and used older sandisk 32gig.

It remains the same. Sometime it freezes even when I navigate in the menus with no music playing.

Now on the last try with the small 32gig card different glitch appeared - it showed Panic dc_writeback_callback () Could not write sector 28 6957 (error -53).
After that RB sometimes boots, sometimes not (showing white screen with apple's sad looking ipod). This did not showed when using dual 256gigs, but the test period was not logn, sice freezes showed quick.
Now I am not able to differenciate if the problem is in the iflash, ipod, wrong install, wrong RB build, bad sd cards...

Any thoughts what could I try next?
Any advice would be much appreciated.
Thank you very much!

I found out few more thing which I did no try - setting the UDMA, DMA modes, etc. which I do not really know what it is and how to do it.
Also when I tried rb 2 years ago, one user "Pommes" gave me advice that RB works when it is not writing on the memory.
I tried not to use directory cache and no database, but still similar problems appeared.
more on my first attempts here:,53166.0.html

Edit - one more strainge behaviour - many times when I switch the ipod on it shows apples sign saying "battery is very low". I usually leave it charging until it disappears.
But when it boots (even few seconds after that) to RB or OF, it shows more than 90percent charge...
The battery is very old, maybe even original which I plan replacing if the RB getts working on it. But now I thought it could contribute on the problem..?

My ipod 4G photo (A1099),  equipped with "Super Talent" 1.8inch (now impossible to find) brand SSD,  started having problems with disk corruption after I uploaded some new music and tried to rebuild the database on rockbox 3.15. I decided to try upgrading to  the latest dev version of rockbox and it seems fine now: rebuilt database, I installed a few themes, and have been using it a few hours without any panics. Is there anything diagnostic I can do to verify/check the filesystem?

Just for fun, I tested my other ipod 4G b/w (A1059), equipped with an el-cheapo chinese CF-IDE adapter with a 128GB Sandisk SD card in it, with the last nightly dev build of rockbox. Total failure: any attempt to play a file or build the database results in:

dc_writeback_callback ()
- Could not write 202617 (error -4)
pc: 00071fb8
sd: 4000b578
    A: 0007f594
bt: end

The numbers vary, but it's always something to do with dc_writeback_callback().

My ipod photo (A1099) continues to work without probems, but it has something closer to a real hard drive in it.

I've never figured out why those cheap generic adaptors sometimes work and sometimes don't.  Haven't tried one in a 4G but I've made a few that worked in 5Gs with 128gb cards, and even a couple that worked in 6Gs.  But others have entirely failed to work.  Something about them is very 'borderline' in terms of timings or something I guess, and maybe it depends on the memory card used?

Well, whatever the problem is, the A1059 w/Chinese junk adapter works with Apple's firmware. Is there something I else (other than UDMA) I can enable/disable in the rockbox source code that can make it just do whatever Apple's firmware does?  I recall some discussions above about defining some variable in some header to set UDMA to OFF, 1, or 2....but I thought that was all straightened out a while ago. If you look in firmware/target/arm/pp/ata-target.h, it says:

#if CPUFREQ_NORMAL >= 30000000 && !defined(IPOD_4G)
#define ATA_MAX_UDMA 2
#elif CPUFREQ_NORMAL >= 24000000
#define ATA_MAX_UDMA 1
#error "CPU speeds under 24Mhz have not been tested with DMA"
/* The bootloader runs at 24 Mhz and needs a slower mode */
#define ATA_MAX_UDMA 1

Can I define something to disable DMA altogether?
Maybe #define ATA_MAX_UDMA 0 ? Has this already been tried?


[0] Message Index

[#] Next page

[*] Previous page

Go to full version