Support and General Use > Hardware

IPOD (ALL MODELS) iFlash Adapter Issues [SOLVED!?]

<< < (17/17)

karmazine:
Hello,

I bought iFlash quad back in 2018 for my ipod 5th. Tried RB, not worked (freezing, skipping tracks) - possibly due to RB issues with flash memory.

Now I found these updates so I gave it a go again. I picked the dev build, and daily build. Main question - are the Speachy's changes incorporated in the daily/dev builds?
I thought yes, so I tried them both.
I formatted the drive to fat32 in Aomei partition sw. Restored ipod in itunes. It seems working in the OF, even showing the disc size corretly (even when I had 2x256).
Then I installed RB (daily and second time the dev build). I installed it with itunes/ipod processes killed and in normal OF mode (connnected to Win pc), not the Apple disc mode (could be issue?).
I did put there the music right after instal, just a few gigs .

It shows slightly different glitches: I am able to play one album, but navigating more and putting more tracks to the "on the go" playlist causes freezes. The music usually plays but the display is frozen and the buttons are not doing anything.
So I thought maybe the micro sd cards are causing problem. I took off both Samsung Evo plus 256gig, and used older sandisk 32gig.

It remains the same. Sometime it freezes even when I navigate in the menus with no music playing.

Now on the last try with the small 32gig card different glitch appeared - it showed Panic dc_writeback_callback () Could not write sector 28 6957 (error -53).
After that RB sometimes boots, sometimes not (showing white screen with apple's sad looking ipod). This did not showed when using dual 256gigs, but the test period was not logn, sice freezes showed quick.
Now I am not able to differenciate if the problem is in the iflash, ipod, wrong install, wrong RB build, bad sd cards...

Any thoughts what could I try next?
Any advice would be much appreciated.
Thank you very much!

p.s.
I found out few more thing which I did no try - setting the UDMA, DMA modes, etc. which I do not really know what it is and how to do it.
Also when I tried rb 2 years ago, one user "Pommes" gave me advice that RB works when it is not writing on the memory.
I tried not to use directory cache and no database, but still similar problems appeared.
more on my first attempts here:
https://forums.rockbox.org/index.php/topic,53166.0.html

Edit - one more strainge behaviour - many times when I switch the ipod on it shows apples sign saying "battery is very low". I usually leave it charging until it disappears.
But when it boots (even few seconds after that) to RB or OF, it shows more than 90percent charge...
The battery is very old, maybe even original which I plan replacing if the RB getts working on it. But now I thought it could contribute on the problem..?

Navigation

[0] Message Index

[*] Previous page

Go to full version