Support and General Use > Hardware

IPOD (ALL MODELS) iFlash Adapter Issues [SOLVED!?]

<< < (16/18) > >>

I've a modified iPod Video with original iFlash adapter.

It's been a while since I checked (,51957.msg240446.html#msg240446) and I still seem to have the same issue.

I cannot use the latest developer builds though this thread seems to indicate I should be able to. The model of the iPod mainboard is MA446LL.

Things I have tried:

- overwriting the files in the .rockbox folder with latest build
- replacing the .rockbox folder entirely with latest developer build

But still the system freezes when I try to go into Files or Database, or even System->Rockbox Info freezes.

Only restoring the third-party modified build I downloaded years ago works but I get some stuttering on playback of some files and I was hoping to try a newer build to solve this.

Edit: Stuttering was *user error*. Files were stupidly high bitrate .flac copied directly to the device, setting up a device profile in MediaMonkey to transcode to a more reasonable bitrate fixed that. Still, I cannot use the latest dev builds and I don't know what I'm missing out on. :-| On the other hand I'm listening to music on the device again.


I bought this iflash ata1 ( to revive my old iPod 4g color/photo with failing hard disk. I ran Rockbox on it years ago and wanted to go back to those glory days. The iflash says 2021 on the actual hardware, so perhaps it's a new model?

I'm running the latest dev build (rockbox-ipodcolor-20220215). I'm using a PNY 512 GB SD card.

I copied some music to the device using the disk mode (holding select and play when booting up).

Unfortunately, I have a couple of problems that I've seen mentioned around this thread, too:

* After installing the iflash and restoring the disk using iTunes, looking at the disk with disk partitioning software gives an "Unable to detect file system" error.
* After installing Rockbox (using the Rockbox Utility on Linux) I can't play back any music, it gives an "error accessing playlist control file" error. I can browse the files and everything seems to be there. I tried with mp3's and flac's.
* Also, interestingly, I cannot run any(?) plugins. (I haven't tested them all, but at least the calculator and image viewer didn't work.)
* Different themes than the default will also not load.
I was afraid this was a hardware problem—that my SD card was faulty—but this thread at least makes me hopeful that that might not be the case? I saw the suggestion of setting ATA_MAX_UDMA to 1 in reply #30 (,52560.msg247796.html#msg247796) but looking at the code of the currect dev build I don't think that can still be done in the same way. That is, reading the comments and code seems to suggest that it should already run with ATA_MAX_UDMA set to 1, as I'm running a 4g iPod.

I'm not sure if it's relevant, but looking under Debug and "View disk info", it says "DMA mode: UDMA 2". Shouldn't that say UDMA 1? I have no idea if that's how this works, unfortunately.

Could it be that the fixes implemented only work for the 4g greyscale model?

My next step now is to setup gcc and try to compile Rockbox with all instances of ATA_MAX_UDMA set to 1 in the ata-target.h file. No idea if that will do anything but I figure I can always try. I would appreciate some help, though!


I compiled a version of Rockbox where I replaced all instances of "ATA_MAX_UDMA 2" with "ATA_MAX_UDMA 1" in ata-target.h. Plugins and themes seem to work now as well as music playback. Only tested it for a few seconds so far, though. Under Debug->View disk info, there is now also "DMA mode: UDMA 1". All this leads me to suspect that the fixes for the 4g iPod version were only implemented for the greyscale version.

Will test further.


Well, it is more stable than before, but the system seems to freeze up after a few minutes of use. Seemed to happen more the more files I copied to the player. The screen still lights up when I touch the scroll wheel, but the selected text becomes garbled after a while. Even when browsing settings without playing anything just now, it froze up. It seems to be busy with something. In any case, not really usable yet.

If I reboot and then as quickly as possible go into files and select something to play, it does seem to work for a short while. Browsing to other files quickly leads to more freezing and garbled text, however.

I took a screenshot of when this happens:


Well, I experimented a bit more, and talked with Bilgus about it on the IRC channel, and I think the conclusion has to be that my SD card was simply faulty. Trying with a 4gb SD card seems completely stable, also with the latest development version (where UDMA is 2 and DMA isn't disabled). For whoever is interested, perhaps with similar woes, you can find that in the IRC logs of 17 & 18 February 2022. I'll shop around for a new SD card, I suppose.

Interestingly, I managed to get a working FAT32 drive in the iPod manually, without iTunes. I combined the instructions here and here

1. Download the MBR file and an ipsw file for your iPod model (doesn't matter which original disk size, I think).
2. Follow steps 1, 2 and 3 of the Rockbox page (dd MBR onto ipod.)
3. Use fdisk on the iPod, now delete the existing second partition (press d, then select partition 2)
4. Follow the steps on from "Create the data partition to fill the rest of your iPod." (I.e. create a new partition just filling up the rest of the free space (I used the defaults fdisk proposed), set type to W95 FAT32, write to disk, but don't do mkfs.vfat -F 32 /dev/sdX2 yet)
5. Follow steps 5, 6 and 7 on the Rockbox page (dd the Firmware on partition 1, then mkfs.vfat partition 2.)

Voilà! This way partition software can also read the file system. (Restoring with iTunes gives an "Unable to detect file system" error in partition software.) This worked on my iPod Color/Photo. I might have done the mkfs.vfat before copying the Firmware. If it doesn't work you can try playing with the order here.

I have a problem with current daily builds (April 21, 2022) for an iPod Video using iFlash solo, the problem is that the player doesn't respond to button press or click wheel movement in Rockbox, these things work in the diagnostic and in iPod mode. I was using this iPod previously and deleted the firmware to use the SD for other things and now I can't get it to work. At least I can reset the iPod in Rockbox mode, but nothing else. Also the lock symbol pops up sometimes and the player seems to go on and off if let alone for a while. I thick that the current dev revisions might not work all too well with my device.

I was able to fixed it by removing the bootloader and .rockbox file, turning on my iPod and using for less than 2 minutes and trying again with the development version and only the Bootloader and Firmware now it works. I am writing all of what I did, no idea if it did something, but hope it helps someone with a similar problem.

likely you just got the build with a bad initialized viewport flag and now you have the fixed one


[0] Message Index

[#] Next page

[*] Previous page

Go to full version