Installation / Removal > Sandisk - Installation/Removal

ISSUE W/ 3.14 VERIFIED: Can't install on Fuze V2 (ATA error -2)

(1/3) > >>

**Updated, please see post 5 below**

Hey folks,

I lent my Fuze v2 out and removed rockbox. Now I have it back and I"m trying to put RB back on but I'm getting stuck.

First I used the utility. After the update and reboot, it goes into the RB root menu, however when I turn the player off and on, it shows RB logo and then halts at ATA error -2. I was able to go back to the Sandisk factory FW by left-booting with the original FW bin in the root.

I then did a manual bootloader patch and tried again with the same result as before - one good boot, then ata -2 after turning off and on. I have since gone back to the Sandisk firmware and have not attempted more.

At first I thought it was a bootloader issue, but since it boots to RB logo and also lets me left-boot into original firmware, it occurs to me that the bootloader is fine, and that something else is acting up.

Any advice is appreciated - I need gapless!

Thanks :-)

Update: I re-copied .rockbox directory and re-installed the patched bin. First boot still works but it complains about missing .rockbox directory. The file list only shows the SD card. And when I plug it in to USB with RB running, the computer shows both drive letters but the internal storage tells me to insert a disk. The SD shows without issue. So it seems like the bootloader isn't seeing the internal storage at all. Original Sandisk FW shows both drives without issue. Continuing to troubleshoot now...

Update: I determined that the root cause is the bootloader being unable to see the internal memory at all. ATA error only occurs with no SD installed. Installing an SD means it boots but complains of no .rockbox folder. I have solved it for now by simply putting .rockbox on the external SD. The bootloader successfully looks for it there, so yay! and thanks again millions to the developers.

If anyone has ideas about how to fix the internal storage issue, please let me know. Perhaps an older patcher? For now I am tired of experimenting :-)

Update: I tried patching OF 2.3.31 (instead of the newest). I booted without SD and got a message "No Partition Found Insert USB Cable and fix it". So I thought, great, it sees the internal drive. So I booted into OF, used the built in sansa "format this player".

Then booted into RB, it told me there was no folder = ok we are getting somewhere.

Then I added the .rockbox folder and rebooted and now I am back to the ATA error: -2

So now I'm thinking this is related to the .rockbox folder version and has nothing to do with the bootloader. The testing continues.

** Issue Verified **

Here are the results from my testing:

RB Version (copied to both internal AND SD card)Boot result without SD insertedBoot result with SD insertedrockbox-sansafuzev2-3.13Boots correctly, internal files availableBoots correctly, both drives availablerockbox-sansafuzev2-3.14ATA error -2ATA error -2rockbox-sansafuzev2 (dev build)No Partition FoundBoots from SD, only ext SD drive is available


[0] Message Index

[#] Next page

Go to full version