Support and General Use > User Interface and Voice

[Sansa Clip +] RockBox Noob Here, SD Card Not Visible in UI


Apologies if this is the wrong board for this topic! I recently installed Rockbox on my Clip+ without a hitch, and already tested the playback by loading some albums onto the internal memory, which worked fine. I started adding music to my SD card to add to my collection, but the system doesn't seem to want to acknowledge it at all. The card is an acceptable file size, and is formatted to Fat32 correctly. My first attempt I just plopped the artist's folder into the root of the drive and plugged it in, and I got nothing, even when I updated the database. I tried mimicking the format of the system's file layout and trying it that way, but also nothing. I've searched for the songs manually in the files tab, but it doesn't seem to detect an external drive to explore. I've tried turning the device off and turning it back on with the card inserted in case it did some kind of check on system startup, but that didn't work either. When I plug the Clip into my computer, it detects both the Clip's internal memory and the SD card as separate partitions, but both are healthy and easily picked up by the computer. I don't get any kind of message from the Clip that the card is unreadable or anything, it doesn't seem to be checking for it at all. Is this an issue with my device, or am I just using Rockbox incorrectly? Do the files in the SD card have to be arranged in a certain way for rockbox to recognize it?

Very sorry if this is an easy fix that's outlined in the manual or something, I checked the manual as thoroughly as I could, but I didn't find much relating to expandable memory beyond the formatting information.

Is there a <microsd> folder in the root directory?


--- Quote from: __builtin on August 19, 2017, 06:43:03 PM ---Is there a <microsd> folder in the root directory?

--- End quote ---
There does not seem to be, no.

Not sure why It would see it when you plugged in to usb but not in the player, You might try formatting to Fat-32 again, perhaps try a Full format or use RMPrepUsb
also you would access the MicroSD folder on the device from MainMenu>Files><MICROSD>

--- Quote ---,51941.0.html

actually even though you reformatted it it probably still has the remnants of ex-fat still on there and RB doesn't like it

Are you using windows or linux?

in windows try:

HDD LLF Low Level Format Tool

truthfully you could probably do a full format in windows too but I know both of these do the job

if in linux could you get us a dd of the boot partition before you do a full format?
sudo sfdisk -d /dev/sd# >file.txt
--- End quote ---


[0] Message Index

Go to full version