Installation / Removal > Apple - Installation/Removal

I formatted my rockboxed ipod classic 6g

(1/2) > >>

As the title, I formatted my ipod classic 6g thinking the bootloader/rockbox core was installed in a hidden disk, but apparently, it isn't.

When I boot, on a white screen it says

--- Quote --- *PANIC*
 mount: 0
pc: 22021CAC sp: 08800B38
bt end

--- End quote ---

When press down SELECT+MENU, on a black screen it says:

--- Quote ---Rockbox boot loader
Version: 1.0
Battery status ok: 4085 mV
No partition found

Entering USB mode...
Plug USB cable

--- End quote ---

When I plug it to my computer,
--- Quote ---Plug USB cable
--- End quote ---
changes to
--- Quote ---Bootloader USB mode
--- End quote ---
, but when I unplug, it goes back to the aforementioned white screen with the same message.

I tried to use Rockbox utility to reinstall, manually installing rockbox by using ipodpatcher, restoring with itunes, but I've had no luck so far. When I try to install the bootloader with rockbox utlity, the message returned is

--- Quote ---Could not find mounted ipod.
--- End quote ---

I think the problem is that because I formatted the disk it is no longer recognized as an ipod. I am not sure if I've completely fucked up my ipod, or there is still a solution.

Thank you in advance for your replies.

Unless it's suffered an actual hardware failure you really should be able to restore using iTunes.  Maybe try holding down menu+select long enough to put it in recovery mode while connected, iTunes ought to detect ipod in recovery mode and proceed to restore it.
Possibly the second message you are getting is because you aren't holding menu+select long enough for it to actually go into recovery mode and it's just trying to reboot into rockbox.

Tried holding down MENU+SELECT while connected to the computer but no luck... the screen shuts off then the Rockbox bootloader screen pops again. Tried with itunes open and without.

So it rebooted while you still had the buttons pressed?

Sorry, don't know what to suggest, though the thing is, I did have this exact problem at one point with one ipod, but if I remember correctly (and am not sure I do, have gone through loads of ipods and swapped parts around at times) it just eventually fixed itself after I'd disassembled it, given up on it for a bit, and later put it back together again only to find it now worked.  But then again, it might be one that later stopped working again.

Can it get into diagnostic mode?


I had the exact same problem. Don't stop holding down the buttons when the boot screen appears. KEEP PRESSING! :)


[0] Message Index

[#] Next page

Go to full version