Third Party > Repairing and Upgrading Rockbox Capable Players

SanDisk Sansa Clip+ Recovery nand

<< < (2/4) > >>

Mihail Zenkov:
Did you do dump of nand before writing on it? Maybe firmware should be written with some offset or should have some special formatting.

We still don't know how internal drive work: from software (driver) point it looks like ordinary SD card. So player should have sd to nand controller and probably some configuration bits for it.

Dongs at IRC ( try replace nand. You can try to ask him.

I formatted NAND, and then put in the firmware. And, perhaps, the size of the flash drive is different, because of this does not work in the player? (The working NAND in Figure 1 of the player, and the second is not a robotic NAND in the player, see Figure 2)

There is some information on the AMS SD formatting on the wiki, but it is complex because so many different players and two hardware revisions exist, so not all of it may be exactly right on the clip+.  My memory is that the stock firmware is stored as an image at the start of the SD which is hidden by the firmware.  The rockbox SD driver can read/write this area, but we hide it to keep the user from damaging the stock firmware.  When you short out the NAND and get the player to boot up in the "recovery" mode, you see the entire SD up to the first few GB, including the firmware.  Below the level of the SD (and unaccessible to rockbox) is the raw NAND, which probably includes some additional space used to store the SD to NAND cell mapping. 

I think ideally you would need an image from a desoldered NAND chip to flash to a new NAND.  This should set up the NAND with all the SD translation tables.  If you don't have that, the SD controller may be smart enough to recreate it, or it may refuse to boot.  I don't think anyone beyond Dongs ever looked at it, and he did not get it working. 

thanks for answers! Tell me please, is this JTAG correct for the firmware of the player?

Similar story to me.  :(
NAND is died, I had all of the symptoms was not able to boot rockbox or OF. I tried many of recovery manuals but had no luck. I tried so many times that resulted shorting 29-30 pins gives only 32MB storage and never 3.9GB.
Then I tried to replace NAND with well known Samsung 2GB one - no success, since bootloader has no support other nand ID than SANDISK.
I tried to find any new or used SANDISK NAND ICs with known IDs on e-stores but have no luck. Probably few years ago I'd find some USB stick with Sandisk NAND TSOP48 but not this year - only have found Samsung or Hynix NAND on sale.
Then I found USB stick based on PHISON PS2251-61-5. I replaced NAND form that USB stick with my Sansa's NAND.
Then I used UPTool_Ver2094 software for low level scaning NAND, found out that there were 234 Bad D3 Blocks that actually not so much and the tool can do sorting, low and high level format. I made the USB stick operate with Sansa's NAND, only 3.7GB remains, but it was promising... I wrote on it full RAW data from recovery image that it found here
Then I moved NAND back into my SANSA, but it had nothing to work... It still have only 32MB visible and no visible NAND. I give up, but there is only thing I didn't do, is JTAG recovery.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version