Installation / Removal > Cowon - Installation/Removal

Installing rockbox onto Cowon D2


Hello all!

Managed a little while back (though I've never used it up until today!) to get hold of a second hand cowon d2 from ebay. The device seems to work fine with its own firmware.

I have been trying (with debian linux) to install rockbox onto the Cowon D2 but haven't had any success in getting it to boot. The first thing I found I had to do is to update the D2 itself; mine still had an older version 2.54 firmware. According to the documentation in order to patch the firmware you need the same version as on the player but I couldn't find any original D2 firmware for version 2.54 .

So the first task I did was to update to the latest version I could find for the D2, version 2.59 . This worked and the player now reports in the original firmware version 2.59 at boot. Seems to power up and work.

I Then build the software tool (mktccboot) and patched the firmware and flashed. That seemed to go ok too -- powering on the D2 brings up the original firmware; powering on and then sliding the switch right towards the 'lock' symbol (and which reveals a small orange spot on the switch) brings up the rockbox logo.

Unfortunatly that's as far as I can get. I understand that I need to unzip the rockbox software itself onto an SD card and boot from that (it should contain a .rockbox directory, which it does). Unfortunatly rockbox never starts -- it displays the logo for a few seconds before going to a blank, empty screen.

I tried three different SD cards and even a couple of micro sd cards in a SD to microsd converter. The result was the same -- nothing.

I also tried formatting the SD/microsd cards with and without a partition (using FAT32). Still nothing! (mkdosfs -I can be used to format a whole SD or micro sd card without a partition as FAT32; mkdosfs -I /dev/sdX formats a partition only; I tried both of these).

I used fdisk to check this with the partition, it reports the partition as (for example) /dev/sdc1, W95 FAT32.

Concerned that I might have a broken D2 I checked to see if the original firmware could read *anything* off an SD card by copying a jpeg image and using the original firmware to see if it could read it. Fortunatly, it did and I could view the jpeg off the SD card with the original firmware ok proving that the sd card works, and the device itself does.

Not so for rockbox, no matter what I try I can only get the rockbox logo to appear and then nothing!

I Did see this thread:,24282.0.html

....but I do not think my problem is to do with SD/microsd card compatibility. Also the link to the iaudiophile thread in that rockbox thread is long dead.

BTW the version of the rockbox software is the latest version, 20170730 . I also tried a bleeding edge version but have the same problem. Additionally, I would try to use the internet archive to look at those old links but the internet archive is down right now....

Is there something I've missed at all?



The current code has been broken for the D2 for a while now.

cereal_killer spent some time finding a last working version;,51522.msg238092.html#msg238092

You just need to unzip this onto your SD card. Rename the existing .rockbox directory first, to avoid confusion. Afterwards you should have a new .rockbox dir from the zip.


--- Quote from: ljones on July 30, 2017, 03:14:50 PM ---Not so for rockbox, no matter what I try I can only get the rockbox logo to appear and then nothing!

--- End quote ---

So the screen goes black? The player shuts down? Is there an error message or something? Have you tried Rockbox Utility?

--- Quote from: nick_p on July 31, 2017, 09:56:32 AM ---cereal_killer spent some time finding a last working version
--- End quote ---

No, with the help of pamaury and gevaerts I just compiled a build that doesn't panic.



[0] Message Index

Go to full version