Third Party > Unsupported Builds

SANSA ClipZip Clip+ Fuze+ FuzeV2 Multiboot Bootloader and Firmware

<< < (3/11) > >>


--- Quote from: Bilgus on September 22, 2019, 01:46:49 PM ---do a bootloader install
the bootloader is backwards compatible

rbutil doesn't have the option to install to the sdcard you need a special firmware version for the time being

--- End quote ---

I see... can you please tell me where I can get such firmware and what's the procedure to install it? The links above are all striken out or not available... I guess my Clip+ internal nvram is going bad and I'd like to transfer RB to the external card, before it dies...

Edit -2022-

That is a bit older than the current dev builds but perfectly serviceable
I'm not completely sure how RbUtil handles the bootloader I assume it'll just let you install the new one
If not I can walk you through how to do it manually

The firmware just needs to be unzipped to the sdcard and
a file named rockbox_main.clip+ with a single '/' (no return and no quotes)
made on the root of the card

--- Quote ---The proper layout of file: rockbox_main.<playername> is imperative;
The file either needs to be completely empty for the root of the SD card
or a single slash '/' this will instruct the bootloader to look in SD/.rockbox
The text editor within RB seems to add a (EOF) as does linux so use
'touch rockbox_main.<playername>' in linux
or simply put a single forward slash in the file '/' (no quotes)
--- End quote ---

Oh, I see... thanks for the link. I need some more help, please.

First... some clarification... just in case: when we say SD card it means the external card plugged into the side of the Clip+, when we say internal memory it means the memory on the SoC.

What I did until now:
1. Downloaded and extracted it to the SD (SD card's: /.rockbox) card (that's my drive G).
    Note: that I'm transfering files with the SD card inserted into the Sansa Clip+ booted via rockbox. Is this OK?
2. Created the file on the SD card(!) G:/rockbox_main.clip+ (using cygwin: printf "/" > /cygdrive/g/rockbox_main.clip+). Checked the size, it was 1 byte.

I then went to rbutil 1.4.0 (on Windows) and installed the boot loader on both G: (that's my SD card) and also E: (that's the clip+ internal memory)
I also took care to eject both drives. Note that when installing the boot loader I get asked to provide the original firmware (clppa.bin). I see the firmware
file on the target drive, when finished.

When I rebooted the device I noticed that I'm still seeing all the old playlists from the internal memory (this should not happen, I guess).
I also checked the Debug menu for the Bootdata (is this Debug(Keep Out) ->Bootdata or something else?)... but could find no such entry. How can I check where did it boot from?
I also diffed the contents of SD/.rockbox before and after boot - no new files were created or changed (md5sum of all files under SD card's /.rockbox), which
leads me to believe it did not boot from SD card.

I installed the boot loader using both the stable (3.14) and dev version (5afdcdd) - no difference at all. I also tried to uninstall the bootloader
using rbutil, but it says that the bootloader could not be uninstalled on this device (that I should flash the original firmware to remove it).

I also tried to create empty SD/rockbox_main.clip+ - no luck, either. Heck, (in desperation) I even tried to create rockbox_main.clip+ on the
internal card :)  Still no luck.

I guess I'll need the instructions on how to install the correct boot loader. If possible on windows (cygwin)... or if that's not possible, I'll try to get hold of linux box. Maybe somone removed the multiboot code from the dev build?

The bootloader has to be installed by booting into the sansa firmware
If you are doing it manually the bootloader here is the same one rbutil would build for you

Clip+ User:
First download
unzip the file clppa_new.bin to root of internal storage rename as clppa.bin,
safely remove device then reboot and enter original firmware ( left button on DPAD )
wait till device turns off
Next download MultiBoot_FW_ClipPLUS [latest date] and unzip to the root of your SD card
Finally create an empty file called rockbox_main.clip+ in the root of the SD card
now put sd card in device and reboot; Under Debug menu you should have a new entry 'Bootdata' that lists the current boot drive
if not check that the rockbox_main.clip+ file is actually empty or single slash '/'.

You have already copied your FW on the SD card I'd recommend you eject it prior to booting into the Sansa OF
otherwise it'll make you wait while it indexes it,
put it back after the device turns off when finished updating

Oh, Yeah! :) Thanks, Bilgus!

Worked as a charm - the only minor detail was to set the USB mode to MSC when booted into the original Sansa firmware. Otherwise you see only the MTP Internal Memory device (which you can't safely remove). Did not try the update in MTP mode, though...

I can also see the Boot data menu in Debug and the old playlists are gone!

Thanks again... hope this will prolong the life of my salsa clip until there's (hopefully) a better device to put RB on.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version