Support and General Use > Audio Playback, Database and Playlists

YP-R0 Dont show names

<< < (4/4)

Hi, I recently dug out an old YP-R0 and rockboxed it while I was at it, but ran into the unicode bug mentioned in this thread.

Using lebellium's build posted above does fix it, so I take the fix was never merged? Unfortunately commit link and anythingbutipod forums are gone along with the bug explanation.

Since that build it's based on an older rockbox and there is a handful fixes for the YP-R0 since then, it'd be nice to have newer fixed builds. Plus in the build, "files" somehow start in Linux's root rather than /mnt/media0 (not a dealbreaker but a bit strange, tried fixing it with but nope).

To re-explain the bug, microSD card won't show unicode filenames (with utf8 codepage and proper unicode font; internal memory filenames and WPS aren't affected). However after ejecting and reinserting the card rockbox will display them, so I guess it's a mount_sd() issue in system-ypr0.c, perhaps not correctly un/remounting with utf8 on some *_init. Just in case tried manually doing that in (which I assume inits this port) but no luck.

Could anybody fix this, or point out where the issue could be? (maybe I can fix it myself).


(sorry for the necro, not sure about the proper etiquette here)


[0] Message Index

[*] Previous page

Go to full version