Third Party > Unsupported Builds

[7th gen Apple Ipod Classic Thin] Bose Dock, Database, and Apple OS.


Hello everyone !

This is my first post on here, and let me say I'm impressed with the works ! I first heard about RockBox about two years ago, but as I had a 7th Gen Ipod already, and lots of things on my mind, I looked away for a while, as I'm only an IT Tech (no dev inside :p).

So I now come back to see that my model is supported (well, not really, but still). So I had to try it, and it works wonderfully :). Some things might be a little bit buggy still, but I'll try to participate in pointing out the bugs.

1°/ First night I go back home, I was eager to test things, so I got my Ipod docked to my Bose dock (don't have the model right now, Im' at work, but I can for sure provide it).
First, it only charged, and the screen showed the USB logos, as if it was plugged to the computer.
So I looked around, found about the holding the menu button to force charging only mode. Tried that, now I could navigate when plugged, but it was still only charging. Even when a song was playing, I had no sound.
For info (I'm too noob to get info from this, but this might help)
As well as this

I tried to change the settings to Car Adapter ON (which stayed that way), Line Out ON, and Accessory PSU ON too (don't know if the term is correct, my system is in French ;D), it didn't change anything (that I could see anyways).
The only solution I had left was plugging the Audio In as well, there I have sound. It seemed to have a bad quality when I turned up the volume, but there might be some other explanations than the system:
- My Minijack cable is shitty,
- The songs I was playing might have a poor bitrate, I just downloaded them an hour before, I didn't check,
- I had no time yesterday night, so I couldn't check some more.

I looked around, and it seems to be normal that it won't work like vanilla (only with Ipod's charging port plugged in) for now.  I would like to know if it was a planned feature ? If yes, know that I'm voluntary to help on that. I don't really care, as I hate Apple, and can never go back their OS.

2°/ Nevertheless, only for testing purposes, I tried to boot back into the vanilla OS, activating the Hold key as soon as I had launched Rockbox. It said "Cleared...", black screen, and then nothing for five minutes, no responses to inputs. Here I really thought I had bricked it :D, but it booted back into Rockbox after that.

3°/ Another thing, is the database tags not updating correctly. I went back to the settings, selected the folder where the music is stored (\Music\) by clicking 3s on the Select button, when the folder is highlighted. All the subfolders have a green arrow appearing near them (guessing that means it taken account of them, I go back, it asks me if I want to save settings > Yes, then asks me if I want to update the database > Yes. And then it says updating in background.
I had launched that yesterday, and today I went into the databse tags, and only a small part of my music is there. Tried some more times, and it says updating, but stop on 34 tags. I might have around 16000+ songs, and I read the limitations, so I know it's not that. My guess is a faulty format that blocks the updating process.

4°/ Oh and one last thing: I was wondering if that was possible to boot directly into Rockbox menu, without having to through the boot menu (where there is the option for the terminal) ?
I searched quickly in the manual, but didn't find it.

Things to know about my config :
- I have a Windows 7 laptop, and a desktop, and a Windows 8.1 desktop.
- My Rockbox intalled version is e70ea5d-150628.
- The device is a 160GB Black Ipod (I think it's 7th gen, though I'm not sure about that.

1°/ Ipod 7th Gen not working on Bose dock with vanilla Apple plug only (it charges, but no sound)
2°/ Booting back on Apple's OS seems to create a bug.
3°/ Database tags are stopping their update at some point.
4°/ Can I disable the boot menu ?

Here it is, I thinks I told you guys everything, I hope I can help making a bit of this project moving further.
Have a good day, and thanks for having read until there ;)


There is no digital out or dual boot working on the 6G/7G. 


--- Quote from: saratoga on July 16, 2015, 09:44:23 AM ---There is no digital out or dual boot working on the 6G/7G.

--- End quote ---

I'm confused about this - can you explain further?

Rockbox on my 7g works OK with a fiio (powered) portable amp connected to the docking port - though not with the unpowered one.  I understood this was due to Apple encrypting the relevant feature that would let you use unpowered amps.  Is this not correct? 

Is the powered fiio taking an analogue signal from the docking port rather than a digital one?  Or is there some other difference?

(I don't actually need the amp any more, as it happens, because the only reason for it was to get round the low volume with the original volume-limited firmware, which rockbox solves anyway)

Yeah theres both line out and digital out on the dock connector.  Simple devices like amps probably use line out, whereas docks tend to use digital these days (but not always). 

Hi, thanks for the replies,

but you didn't say anything about the bugs I could maybe resolve ;D
3°/ Database tags are stopping their update at some point.
4°/ Can I disable the boot menu ?

Also I've made some tests on the Bose, with the Ipod docked, as well as plugged in with minijack, the remote works only for volume up and down, no more remote skipping tracks, nor playing/pausing :D
Is the dock compatibility a planned feature ?


[0] Message Index

Go to full version