Third Party > Unsupported Builds

iPod Classic 160GB can't get EmCore to install/run

<< < (2/6) > >>

Hi again [Saint]!

That was really really managed to find the cause of the problem! I ejected the device from the Explorer menu (as it is described in the EMCore installation...I cannot believe I didn't see that in the first place...), and tadaa! The EMCore Installer starts, asking me to continue. I go ahead and end up in the menu (on the iPod) where I can select Rockbox. It goes on, and the USB cable is finally shown on the screen.
In the EMCore installation, it says "follow the instructions on the screen". I don't know if that's supposed to happen, but my computer (Win XP) showed the USB tray icon popping up quite a lot of times...until finally a window pops up, asking me to install "EMCOre debugger" driver. I click yes....and it tells me the installation failed. I guess that is NOT supposed to happen.
I continued anyway, starting Rockbox utility. There, I cannot go anywhere. When I try to select the iPod, it tells me "Mounting point inaccessible" or something like that. The iPod also doesn't show up in the Explorer.
Do you (or somebody else) have ANY idead what I could do now?
If everything fails....can I actually get back to the original iPod firmware? Or are chances high that I wrecked it totally now?

Thanks in advance for any help,

I'm REALLY starting to notice that the installation of RockBox on an iPod Classic is a strong case of "the devil is in the detail".
I got at least a small step further, however I still cannot get it working. Maybe this is going to help anyway, as I noticed some things:
1) Obviously the "Emcore Debugger" thing is not important after all, or at least not the cause of my problems. 
2) The reason for all this trouble seems to be the "Apple Mobile Device" driver. It says in the EMcore wizard that the process has to be killed in task manager. Which I did. What I did NOT notice at first, is that this process is being started automatically every half a minute or so! So what I tried is this: Start the boot menu on my ipod, select Rockbox, and wait for all the error messages to disappear. Rockbox starts up (or what I guess to be the fallback image with tiny letters and no colors). Then I opened the task manager on my computer, killing the Apple Mobile Device process. THEN I connected the iPod again, also opening Rockbox utility on my computer.
NOW the mounting point is accepted. The furthest I got was the menu where I can select what I want installed with Rockbox (fonts, themes....). However, then, at the latest, the Apple Mobile Device driver would be started again, and before I could kill it, the installation process would mess up once again, complaining about the wrong mounting point.
My last idea was to prevent Apple Mobile Device from starting in the first place. I opened msconfig and removed the tick next to the process. After the required system restart, I tried everything again. It still didn't work, although the Apple Mobile Driver was not started. The "iPod Classic" would show up at mounting point "G:" for about 5 seconds, and then disappear again completely. Thus, I still could not go ahead with the installation of Rockbox.
I hope this could at least clear up the problem a little!

Any help would be greatly appreciated!


Has no one got any idea? Maybe some similar experience?
At the moment my iPod lies around unused, because it's almost worthless for me without RockBox :-(

Since iTunes is now absolutely irrelevant - why not simply remove it entirely?

Though I'm willing to bet that simply uninstalling the device drivers will have a similar effect.


Someone gave me the simple idea to check USB connectivity on a different machine, possibly without iTunes.
Luckily, I have a Windows 7 laptop in use, and there has never been any Apple software or any drivers of that kind on it.
So I connected the iPod to the laptop... and I was happy (at first), as it recognized the iPod and successfully installed the drivers. However, when I opened RB Utility to continue the installation...I received the same error as always. "Mounting point does not exist".
So either I forgot something really important during the installation of EMCore or the problem has to be the iPod itself. Otherwise I wouldn't get the same problem on 2 completely different computers, right? What about the rumor that some iPod Classics have an incompatible hard drive? Could that be it?


[0] Message Index

[#] Next page

[*] Previous page

Go to full version