Rockbox Development > New Ports

Creative ZEN X-Fi

<< < (12/13) > >>

Dear Community,
I need your help.
I have tried some time ago to install Rockbox on my mp3 Player (Creative ZEN X-Fi). at some point I have restarted the mp3 player, perhaps in the middle of the firmware update or something... I can't tell exactly any more. :-(
Right now I at this point:
the player does not start, Windows recognizes the player only as HID device.
I have found on the Internet a tool sbloader which "pamaury" has compiled (many thanks to him) and I am sending with this tool the file ZENXFI_PCFW_l22_1_04_08e_rk_fresc.nk to the Player. This is the only way to wake it up.
Then I wait for it to start (it only enters in recovery mode). Then I do a update Firmware on the mp3 player - which should erase the Firmware (it gives an error message at the end: "Media problem").
after that I try to send the OF (ZENXFI_PCFW_l22_1_04_08e_rk.nk)  to the Player with sendfirm (I also tried it under Linux - sendfirm32).
with the following results:
1. mostly I get an error message - not possible
2. under Linux I get a black Screen at the beginning and then some error Messages - the player does not react in any way...
The creative tool detects the firmware version tries to update but it gives an error message "Firmware update failed".

Can anyone clarify the status of this port?

Stable, says
Unstable, says

the wiki has an edit data of 11 Nov 2013
2016-09-21: Promote ZEN X-Fi to stable

So I'd say someone forgot to update the wiki

If anyone knows what improvements were made to the port to justify the 2016 change to Stable, it would be great if they could update the feature status table accordingly.


--- Quote from: pamaury on September 23, 2016, 05:10:11 PM ---Hi again,
here is the linked to the prebuilt bootloader. It is version V1_RC:
To install it, follow the instruction from the wiki:
in a nutshell: enter recovery mode, reload firmware, plug device, use sendfirm to send the new firmware

As a side note, I tortured my ZEN X-Fi by rebooting many many times and I was indeed able to have a black screen on boot after 20 attempts or so. So the problem might still be there.

--- End quote ---

I apologize for resurrecting a dead thread, but after years of having what I thought was a bricked X-Fi, I managed to get this specific bootloader to work! I had to utilize the Linux sendfirm tools since sendfirm.exe didn't want to work with Windows 10, but I'm currently uploading music to the device to test it. I just want to give others hope that this does work.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version