Installation / Removal > Apple - Installation/Removal

Installation Problems-Linux (Solved)


Hi, I'm trying to compile Rockbox to work with my iPod Photo. When compiling (Step #1 under the IpodBoot instructions), I run into the error:

AR+RANLIB /home/felix/Desktop/rockbox-bleeding/build-dir/librockbox.a
make[1]: *** [/home/felix/Desktop/rockbox-bleeding/build-dir/librockbox.a] Error 127
make: *** [all] Error 2

I'm not quite sure what's wrong. I think AR and RANLIB have to do with gcc, but I don't know much about compiling other than your standard ./configure, make, make install.

Any ideas?


Never mind. I fixed it. ;D

Forgot to copy bootloader.bin into the right directory.

Okay, so I've run into another problem.
I'm not sure which partition I'm supposed to load the rockboot.bin file onto. sda1 is the first partition of my ipod, and sda2 is the FAT32 partition.
Also, I ran into a problem booting rockbox, which gave me an error message -1.

Thanks for any help.

rockboot.bin should be copied to /dev/sda1 using a command like:

dd if=rockboot.bin of=/dev/sda1

But from your second question, it sounds like you have already done that.

error message -1 means that you don't have Rockbox itself installed.

If you're compiling yourself, then the following commands are needed:

mkdir build
cd build
[Choose your ipod, and then "N" for a normal build]
make zip
unzip -d /mnt/ipod/

The "make zip" command creates the archive, and this needs to be unzipped onto the FAT32 partition on your ipod.  Alternatively, just download the very latest for your player here:

Okay, the firmware works, but now I can't seem to be able to mount the iPod.

How should I change my fstab?


EDIT: Do I need to change the FS type to usbfs? That's the only way I can mount the drive at all. Vfat won't work.
EDIT2: fdisk -l /dev/sda returns that sda2 has both logical and physical endings. Could this be the problem?
EDIT3: Problem solved through a reboot.


[0] Message Index

Go to full version