Rockbox General > Rockbox General Discussion

Simulator problems

(1/4) > >>

I just can't get the simulator to compile in linux...
I'm getting loads of undefined reference errors... this is how it starts:

--- Code: ---LD rockboxui
/home/Martin/build/_rockbox/sim/libcomsim.a(io.o)(.text+0x7b9): In function `sim_codec_load_ram':
/home/Martin/build/_rockbox/uisimulator/common/io.c:354: undefined reference to `dlopen'
/home/Martin/build/_rockbox/sim/libcomsim.a(io.o)(.text+0x7e3):/home/Martin/build/_rockbox/uisimulator/common/io.c:362: undefined reference to `dlerror'

--- End code ---

Then it goes on to lots more undefined references with X in the name:

--- Code: ---/usr/lib/libSDL.a(SDL_x11events.o)(.text+0x969): In function `X11_KeyToUnicode':
: undefined reference to `XLookupString'
/usr/lib/libSDL.a(SDL_x11events.o)(.text+0xa2b): In function `X11_SetKeyboardState':
: undefined reference to `XQueryPointer'
/usr/lib/libSDL.a(SDL_x11events.o)(.text+0xc2e): In function `.L127':
: undefined reference to `XQueryKeymap'
/usr/lib/libSDL.a(SDL_x11events.o)(.text+0xc97): In function `X11_PumpEvents':
: undefined reference to `XNextEvent'
/usr/lib/libSDL.a(SDL_x11events.o)(.text+0xf20): In function `.L168':
: undefined reference to `XCheckTypedEvent'
--- End code ---
This goes on for pages and pages (full log file attached)

I've only just installed linux so I thought I'd probably not installed a certain package, but as far as I can tell I've got all the Xlib packages and SDL packages..

Anyone have any ideas?  ???

[attachment deleted by admin, too old]

What distribution are you using? It sounds like your LDOPTS are screwed up and you may have some packages missing from your Linux install (you shouldn't be getting unreferenced symbol errors from within the SDL libs). If you're using Fedora or some RPM-based distro, make sure you have all the relevent *-devel packages installed (sdl-devel, xorg-devel, glibc-headers, etc).

I'm using SUSE9.2 which is an RPM based distro...
I have:

sdl-devel 1.2.9-1
glibc-devel 2.3.3-118
but no xorg-devel...ooh..maybe that's it, I'll give that a go..Thanks
All I needed was a list of what should be installed...


oh well... it didn't work, I still get the same error
Now I also have:

xorg-x11-devel 6.8.1-15.4

Is there anything else that I should make sure I have?

You are getting undef ref errors in your SDL installation which makes me think that whatever SDL packages you installed weren't compiled for your distribution, or you have some other dependency problem. In any event, I suspect your SDL packages are the root of the problem.

EDIT: Problem #1 is that you have different versions of sdl and sdl-devel installed. Problem #2 is that (according to google), the sdl that shipped with SUSE 9.2 was buggy wrt ALSA and possibly other things as well. Uninstall your SDL packages, reinstall SDL and make sure it is at least 1.2.8. Also make sure you update any dependencies.


[0] Message Index

[#] Next page

Go to full version