Installation / Removal > Toshiba - Installation/Removal

Bricked Gigabeat F40 refuses to work, need original firmware

(1/3) > >>

Hi, new to the forums and I'm having trouble.  I have an old Gigabeat F40 that had the headphone jack get messed up, so for the last couple years I've simply used it as a large flash drive for my modded gaming consoles and the like.  However, a couple days ago, a friend of mine managed to fix the headphone jack... we think.  I decided I wanted to check and see if it worked, and I knew about Rockbox already so I figured I'd just put it on and I'd have an MP3 player again.

I should have known it wouldn't be that easy. :\

I have done everything under the sun to get this thing to work -- I've used the dummy files on the Gigabeat page, installed everything correctly and to the correct spots on the Gigabeat, done the hard-drive removal thing and followed everything to the letter, etc.  I'm not incompetent at all when it comes to this sort of thing, I didn't make any mistakes and to make sure I did everything at least 3-4 times the same way and even tried switching up some of the directions when that didn't work to see if it would help.  Nothing I've done has gotten it to change from Error 00000020.  I'm pretty much ready to give up on it, but the one thing I have not done is try using the original firmware with it again.  I don't have the old disc, but I did find the upgrade program online and even that didn't work because it didn't recognize my device as a Gigabeat at all.  I doubt even the original firmware will work, but I have to make sure I've exhausted every option before I completely give up, so could somebody do me a huge favor and upload their original GBSYSTEM folder and message / email me the link?  It'd really be very helpful.

Thanks for your time!


We can't distribute the OF because of things like copyright, which is why we tell you to make a backup before installing Rockbox.

I thought that you could extract the files from the update, but I may be thinking of another player.

Maybe someone with the files will contact you privately.

Ahh, my bad.  I wish I had made a backup, but I've been using it as a harddrive for well over 2 years and had never thought of it being usable again.  Fingers crossed on a kind soul privately messaging me then.  I tried extracting the files from the update with 7zip, but I couldn't actually find where they were.  If anybody knows where in the archive they're located I could try again though.

If you have or can find the original Gigabeat Application Software CD, you can obtain the Gigabeat firmware off of that IIRC.

I can zip up mine later if you want ?
I have the GBSYSTEM folder and a backup of my F40 firmware if you want it.


[0] Message Index

[#] Next page

Go to full version